summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-09-17 20:12:37 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-10-12 12:09:14 +0300
commit56d51e98becd2c7260a91d63ea738d4a0d65dd03 (patch)
tree444be4da8cd5541889b0d85433759726dec20862
parentacct-user/steamcmd: add user for games-server/steamcmd (489) (diff)
downloadgentoo-56d51e98becd2c7260a91d63ea738d4a0d65dd03.tar.gz
gentoo-56d51e98becd2c7260a91d63ea738d4a0d65dd03.tar.bz2
gentoo-56d51e98becd2c7260a91d63ea738d4a0d65dd03.zip
games-server/steamcmd: drop user eclass
Dropped user eclass in favour of acct-* packages. Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/12956 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--games-server/steamcmd/steamcmd-1.0-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-server/steamcmd/steamcmd-1.0-r2.ebuild b/games-server/steamcmd/steamcmd-1.0-r2.ebuild
new file mode 100644
index 000000000000..3b5b42805394
--- /dev/null
+++ b/games-server/steamcmd/steamcmd-1.0-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1 user
+
+DESCRIPTION="This is the command-line version of the Steam client for dedicated servers"
+HOMEPAGE="https://developer.valvesoftware.com/wiki/SteamCMD"
+SRC_URI="https://steamcdn-a.akamaihd.net/client/installer/steamcmd_linux.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+ Steam"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ acct-group/steamcmd
+ acct-user/steamcmd
+ app-misc/screen
+"
+
+RESTRICT="bindist mirror"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="
+ opt/steamcmd/linux32/libstdc++.so.6
+ opt/steamcmd/linux32/steamcmd
+"
+
+src_install() {
+ diropts -o steamcmd -g steamcmd
+ dodir /opt/steamcmd
+ keepdir /opt/steamcmd/{.steam,.steam/sdk32,linux32}
+
+ exeopts -o steamcmd -g steamcmd
+ exeinto /opt/steamcmd
+ doexe steamcmd.sh
+
+ exeopts -o steamcmd -g steamcmd
+ exeinto /opt/steamcmd/linux32
+ doexe linux32/steamcmd linux32/libstdc++.so.6
+
+ newinitd "${FILESDIR}"/steamcmd.initd-r1 steamcmd
+ newconfd "${FILESDIR}"/steamcmd.confd-r1 steamcmd
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}