summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-10 01:14:11 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-10 01:17:54 +0200
commit56e531d27c15620166c918874701fe37c553d523 (patch)
treee13bd3b75cd06eb966cf740014c1667fa43281c7
parentnet-proxy/dante: drop old version (diff)
downloadgentoo-56e531d2.tar.gz
gentoo-56e531d2.tar.bz2
gentoo-56e531d2.zip
dev-vcs/gitolite: migrate to GLEP 81
Closes: https://bugs.gentoo.org/781566 Closes: https://bugs.gentoo.org/589468 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-vcs/gitolite/gitolite-2.3.1-r2.ebuild65
-rw-r--r--dev-vcs/gitolite/gitolite-3.6.11-r1.ebuild100
2 files changed, 165 insertions, 0 deletions
diff --git a/dev-vcs/gitolite/gitolite-2.3.1-r2.ebuild b/dev-vcs/gitolite/gitolite-2.3.1-r2.ebuild
new file mode 100644
index 000000000000..51044fbe8182
--- /dev/null
+++ b/dev-vcs/gitolite/gitolite-2.3.1-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-module
+
+DESCRIPTION="Highly flexible server for git directory version tracker"
+HOMEPAGE="https://github.com/sitaramc/gitolite"
+SRC_URI="https://milki.github.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="contrib vim-syntax"
+
+DEPEND="
+ dev-lang/perl
+ >=dev-vcs/git-1.6.6
+ virtual/perl-File-Path
+ virtual/perl-File-Temp
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/git
+ acct-user/git[gitolite]
+ !dev-vcs/gitolite-gentoo
+ vim-syntax? ( app-vim/gitolite-syntax )"
+
+src_prepare() {
+ rm Makefile doc/COPYING || die
+ rm -rf contrib/{gitweb,vim} || die
+
+ echo "${PF}" > conf/VERSION
+}
+
+src_install() {
+ local gl_bin="${D}/usr/bin"
+ gl_bin=${gl_bin/\/\//\/}
+
+ dodir /usr/share/gitolite/{conf,hooks} /usr/bin
+
+ # install using upstream method
+ export PATH="${gl_bin}:${PATH}"
+ ./src/gl-system-install ${gl_bin} \
+ "${D}"/usr/share/gitolite/conf "${D}"/usr/share/gitolite/hooks || die
+ sed -e "s:${D}::g" "${D}/usr/bin/gl-setup" \
+ -i "${D}/usr/share/gitolite/conf/example.gitolite.rc" || die
+
+ rm "${D}"/usr/bin/*.pm
+ insinto "${VENDOR_LIB}"
+ doins src/*.pm
+
+ dodoc README.mkd doc/*
+
+ use contrib && dodoc -r contrib
+}
+
+pkg_postinst() {
+ # bug 352291
+ ewarn
+ elog "Please make sure that your 'git' user has the correct homedir (/var/lib/gitolite)."
+ elog "Especially if you're migrating from gitosis."
+ ewarn
+}
diff --git a/dev-vcs/gitolite/gitolite-3.6.11-r1.ebuild b/dev-vcs/gitolite/gitolite-3.6.11-r1.ebuild
new file mode 100644
index 000000000000..c83049e8e95e
--- /dev/null
+++ b/dev-vcs/gitolite/gitolite-3.6.11-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+[[ ${PV} == *9999 ]] && SCM="git-2"
+EGIT_REPO_URI="https://github.com/sitaramc/${PN}.git"
+EGIT_MASTER=master
+
+inherit perl-module ${SCM}
+
+DESCRIPTION="Highly flexible server for git directory version tracker"
+HOMEPAGE="https://github.com/sitaramc/gitolite"
+if [[ ${PV} != *9999 ]]; then
+ SRC_URI="https://github.com/sitaramc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 arm x86"
+else
+ SRC_URI=""
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="selinux tools"
+
+DEPEND="
+ dev-lang/perl
+ >=dev-vcs/git-1.6.6
+ virtual/perl-File-Path
+ virtual/perl-File-Temp
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/git
+ acct-user/git[gitolite]
+ !app-vim/gitolite-syntax
+ !dev-vcs/gitolite-gentoo
+ selinux? ( sec-policy/selinux-gitosis )
+ dev-perl/JSON
+"
+
+src_prepare() {
+ default
+ echo ${PF} > src/VERSION || die
+}
+
+src_install() {
+ local uexec=/usr/libexec/${PN}
+
+ rm -rf src/lib/Gitolite/Test{,.pm}
+ insinto $VENDOR_LIB
+ doins -r src/lib/Gitolite
+
+ dodoc README.markdown CHANGELOG
+ # These are meant by upstream as examples, you are strongly recommended to
+ # customize them for your needs.
+ dodoc contrib/utils/ipa_groups.pl contrib/utils/ldap_groups.sh
+
+ insinto /usr/share/vim/vimfiles
+ doins -r contrib/vim/*
+
+ insopts -m0755
+ insinto $uexec
+ doins -r src/{commands,syntactic-sugar,triggers,VREF}/
+ doins -r contrib/{commands,triggers,hooks}
+
+ insopts -m0644
+ doins src/VERSION
+
+ exeinto $uexec
+ doexe src/gitolite{,-shell}
+
+ dodir /usr/bin
+ for bin in gitolite{,-shell}; do
+ dosym /usr/libexec/${PN}/${bin} /usr/bin/${bin}
+ done
+
+ if use tools; then
+ dobin check-g2-compat convert-gitosis-conf
+ dobin contrib/utils/rc-format-v3.4
+ fi
+
+ fperms 0644 ${uexec}/VREF/MERGE-CHECK # It's meant as example only
+}
+
+pkg_postinst() {
+ local old_ver
+ for old_ver in ${REPLACING_VERSIONS}; do
+ if ver_test ${old_ver} -lt "3" ; then
+ ewarn
+ elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
+ elog "Please read http://gitolite.com/gitolite/migr/index.html first!"
+ fi
+ done
+
+ # bug 352291
+ ewarn
+ elog "Please make sure that your 'git' user has the correct homedir (/var/lib/gitolite)."
+ elog "Especially if you're migrating from gitosis."
+ ewarn
+}