summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-01-02 11:53:04 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-01-02 11:54:36 +0100
commit56ef3ac2904e7d791ece59bc4f8a148571f78fef (patch)
treeeea59a796146845f886939f4371bdd9d51a96012
parentapp-emulation/plus42: drop 1.0.9, 1.0.10, 1.0.12 (diff)
downloadgentoo-56ef3ac2.tar.gz
gentoo-56ef3ac2.tar.bz2
gentoo-56ef3ac2.zip
app-emulation/plus42: add 1.0.15
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--app-emulation/plus42/Manifest1
-rw-r--r--app-emulation/plus42/plus42-1.0.15.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-emulation/plus42/Manifest b/app-emulation/plus42/Manifest
index 4f757cbb7db4..dfb51877dc53 100644
--- a/app-emulation/plus42/Manifest
+++ b/app-emulation/plus42/Manifest
@@ -1 +1,2 @@
DIST plus42-upstream-1.0.13.tgz 7587720 BLAKE2B 101e6b58a5421e42340b63f521b3a68766dd2f5ddb73d88c6417bd71f79afc0f20403f7e9c134ff3a8f97259a09e7b67dd47d8f349b8c233c12bf707a5ec7175 SHA512 5e184c2737da8aeb702b8d73af810ae5ab633490470918e3e9bb467ac01cfb912a25ae7ba00cb311fafe7250fc28b474958d55c19e1ec9b3c2280c33b97ae865
+DIST plus42-upstream-1.0.15.tgz 7587812 BLAKE2B 533169b56b99e84cb56f16ed3fa0e34ddfae5dc6307df0dab59d4bb6f67890df1ad7f463322304c1605696d9b6c3fa4a624a75cf7284e70b1b6c3aa7518090dd SHA512 fe2ee765410b3e10b8967cb27d7a32140c45f8e1761e3923ed6093e68ccdafe6d77cb84b3df4d803ca4deff972dbda023bfcc89fbbf9448237791afc2e9c4eb9
diff --git a/app-emulation/plus42/plus42-1.0.15.ebuild b/app-emulation/plus42/plus42-1.0.15.ebuild
new file mode 100644
index 000000000000..89d41071d3b2
--- /dev/null
+++ b/app-emulation/plus42/plus42-1.0.15.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PV="${PN}-upstream-${PV}"
+
+DESCRIPTION="An Enhanced HP-42S Calculator Simulator"
+HOMEPAGE="https://thomasokken.com/plus42/"
+SRC_URI="https://thomasokken.com/plus42/upstream/${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa"
+
+DEPEND="app-accessibility/at-spi2-core
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ alsa? ( media-libs/alsa-lib )"
+
+RDEPEND="${DEPEND}"
+
+DOCS=( CREDITS HISTORY README )
+S="${WORKDIR}/${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.9-fix-makefile.patch"
+ "${FILESDIR}/${PN}-1.0.12-fix-build-intel-lib.patch"
+)
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ${myconf} -C gtk
+ emake -C gtk clean
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C gtk
+}
+
+src_install() {
+ default
+ dobin gtk/plus42bin gtk/plus42dec
+}