summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-14 13:40:25 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-14 13:40:51 +0200
commit56ff3fee7342dfcef12f991304d8381d65bd7291 (patch)
treecb989379aeae6023b03f79a73cace50686cc0111
parentapp-vim/gentoo-syntax: s390/sh/m68k stable wrt bug #666122 (diff)
downloadgentoo-56ff3fee7342dfcef12f991304d8381d65bd7291.tar.gz
gentoo-56ff3fee7342dfcef12f991304d8381d65bd7291.tar.bz2
gentoo-56ff3fee7342dfcef12f991304d8381d65bd7291.zip
dev-util/google-perftools: Needed for the ceph version keyworded on arm64
Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-util/google-perftools/Manifest1
-rw-r--r--dev-util/google-perftools/google-perftools-2.4.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-util/google-perftools/Manifest b/dev-util/google-perftools/Manifest
index 35df40d4523e..b85a3159a2ab 100644
--- a/dev-util/google-perftools/Manifest
+++ b/dev-util/google-perftools/Manifest
@@ -1,2 +1,3 @@
+DIST gperftools-2.4.tar.gz 890402 BLAKE2B f4893d7c9bbd3a8dc5b4d8a25837039261fa32782e13653991002ab666d6e81de637932a8b46c66df219336adcc395a217a4ce32332e8e1558beeb140ea642f2 SHA512 77198c150ee26579adc8f190be0c4ba90a9e3854b006c3aa9252b5863b1fce317fd690c6aa0ed202c81f0bbcfbe2d5f8a182263e77b7fb4fbc6b3e8bfffc9fb0
DIST gperftools-2.6.2.tar.gz 911744 BLAKE2B e5798a2f0f2973f02bccabb2550a9df54319e505fc715795cd836ced631b29bfd8e6f8ddf3c7f6dceb0f166523bb0fa55564b1cbc896c8cd8cfd475263c07c39 SHA512 20c3460f806c6425d54e8d1020f15bc8940aacd7bf1367b03a116fb873bbd6c1e1fbb75df1d0ca341eaec813552fec394327175115ea8442a4b7a1ef17f0df2f
DIST gperftools-2.7.tar.gz 916919 BLAKE2B c48882df45415110c1ec39298e84ec9384f6a82851d95e92435649d2b253b9fb8e29664b474e45881599abf3781731c47ead0b6c454c33be9a207a6a2401a97c SHA512 9aa39689bc18603123204f024ab6dc96099b70a3d304e31ef0cc1e9893cc77bd14ee6eb420e597d40e81e487a2a45e77cf1965873646d056fd4b7bee22a4b0bb
diff --git a/dev-util/google-perftools/google-perftools-2.4.ebuild b/dev-util/google-perftools/google-perftools-2.4.ebuild
new file mode 100644
index 000000000000..da07048b388b
--- /dev/null
+++ b/dev-util/google-perftools/google-perftools-2.4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="gperftools-${PV}"
+inherit toolchain-funcs flag-o-matic vcs-snapshot autotools multilib-minimal
+
+DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
+HOMEPAGE="https://github.com/gperftools/gperftools"
+SRC_URI="https://github.com/gperftools/gperftools/tarball/${MY_P} -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/4"
+# contains ASM code, with support for
+# freebsd x86/amd64
+# linux x86/amd64/ppc/ppc64/arm
+# OSX ppc/amd64
+# AIX ppc/ppc64
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="largepages +debug minimal optimisememory test static-libs"
+
+DEPEND="sys-libs/libunwind"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+HTML_DOCS="doc"
+
+pkg_setup() {
+ # set up the make options in here so that we can actually make use
+ # of them on both compile and install.
+
+ # Avoid building the unit testing if we're not going to execute
+ # tests; this trick here allows us to ignore the tests without
+ # touching the build system (and thus without rebuilding
+ # autotools). Keep commented as long as it's restricted.
+ use test || \
+ MAKEOPTS+=" noinst_PROGRAMS= "
+}
+
+src_prepare() {
+ default
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
+ use optimisememory && append-cppflags -DTCMALLOC_SMALL_BUT_SLOW
+ append-flags -fno-strict-aliasing -fno-omit-frame-pointer
+
+ econf \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --docdir=/usr/share/doc/${PF} \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable debug debugalloc) \
+ $(if [[ ${ABI} == x32 ]]; then printf "--enable-minimal\n" else use_enable minimal; fi)
+}
+
+src_test() {
+ case "${LD_PRELOAD}" in
+ *libsandbox*)
+ ewarn "Unable to run tests when sandbox is enabled."
+ ewarn "See https://bugs.gentoo.org/290249"
+ return 0
+ ;;
+ esac
+
+ multilib-minimal_src_test
+}
+
+src_install() {
+ if ! use minimal && has x32 ${MULTILIB_ABIS}; then
+ MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/gperftools/heap-checker.h
+ /usr/include/gperftools/heap-profiler.h
+ /usr/include/gperftools/stacktrace.h
+ /usr/include/gperftools/profiler.h
+ )
+ fi
+
+ multilib-minimal_src_install
+}