summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-01-13 15:30:07 +0800
committerSam James <sam@gentoo.org>2023-01-14 19:14:37 +0000
commit5702c9425e4b39bd530e6c8e0a5727ed63d1141f (patch)
tree4e4441b4193d3bfa03219ba901bb30bd02c352df
parentsys-libs/libxcrypt: fix build with lld-16 (diff)
downloadgentoo-5702c9425e4b39bd530e6c8e0a5727ed63d1141f.tar.gz
gentoo-5702c9425e4b39bd530e6c8e0a5727ed63d1141f.tar.bz2
gentoo-5702c9425e4b39bd530e6c8e0a5727ed63d1141f.zip
dev-libs/npth: fix build with lld-16
Signed-off-by: WANG Xuerui <xen0n@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/npth/npth-1.6-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-libs/npth/npth-1.6-r1.ebuild b/dev-libs/npth/npth-1.6-r1.ebuild
index bb3c8b84c723..00a8ae2ae917 100644
--- a/dev-libs/npth/npth-1.6-r1.ebuild
+++ b/dev-libs/npth/npth-1.6-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="New GNU Portable Threads Library"
HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
@@ -21,6 +21,13 @@ src_prepare() {
}
src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
econf \
--disable-static \
$(use_enable test tests)