summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-26 19:08:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-26 19:33:16 +0300
commit570a6987865b4a19537905c4b4ad229bcfdb3eb9 (patch)
tree441bdbd8c3d14b22dd24d621fa7a0c796af64f67
parentdev-python/patatt: add 0.6.2 (diff)
downloadgentoo-570a6987.tar.gz
gentoo-570a6987.tar.bz2
gentoo-570a6987.zip
dev-python/boto3: add 1.24.60
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.60.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 1e8754b3187b..3c7fc8790d97 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -13,3 +13,4 @@ DIST boto3-1.24.56.gh.tar.gz 529533 BLAKE2B 7d41281f9cc645e8ca83a71e6eabf1d54373
DIST boto3-1.24.57.gh.tar.gz 530363 BLAKE2B a2f3f39f0de79fc68a32da9bacbef863c705cace82ec4650e17ab89b14f73a456b3583fa3376dc6a62139986063fe0bfade5511fea21d0490c57f9fb65cae425 SHA512 5dd4f0c53f772f5d8d2519e5b1230c5918537af7a265a64670996ff2384e2f8e226d33e91ad4491ce00932d8f99d61d6819ce0d10b0f493a514cef2183ac839c
DIST boto3-1.24.58.gh.tar.gz 530450 BLAKE2B 82746de410c03fd0757d088781a5a2ab8d60e3c63bed127f617aec0ccb1eafd7064aed6087f912466db37c257e02ba7328e5408573c0e429284893c3c8605803 SHA512 1d7f5335cd7c7683224d503f9b2787d8dc4a345cc4d13a2dcfab9e709652ffe5cef8b8866d7a3e0218a7efc30d1029a24bad1d8edf9d47911dead3f2d98435af
DIST boto3-1.24.59.gh.tar.gz 531080 BLAKE2B a5efbe215f2a88c6a48640a4b459c426ce3954a2337c84626f39228437d392fab8ec1cf4aaf53887db00bba70500a57ddfd0752d0f09226c78f70d5875ec852a SHA512 6999fc12826072cfd1b06a89a323cc9f28a0874cca07b1ffd94e223e717cc874701f57c1d7b4f63724e329c1f51522631502e8ef19f640fe75c8c4c14e7ff38c
+DIST boto3-1.24.60.gh.tar.gz 531790 BLAKE2B b1734cb085e49609f46dea3ecc0ffdf5e197d31c69a5514d93b026282b0e1ddf04b72282a339b8076f9318f97548457d3e3db314e899e8eceb3e05d2bfced400 SHA512 a82ad5433ef31abfeacc885c8d5540568ec96c5e6b21a23de8f04eb48569f92dda740862d93c5e8e506e70e60e7d5e55e7cfba17b73e471ef49fc2a827846473
diff --git a/dev-python/boto3/boto3-1.24.60.ebuild b/dev-python/boto3/boto3-1.24.60.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.60.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}