summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-25 01:53:36 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-10-25 01:53:36 +0200
commit57147887aaea5687854624d0ca13793c0f091407 (patch)
treeb39185007ad834f0a3c28f02952e36f0149860d5
parentsys-apps/ipmitool: systemd unit for ipmievd (diff)
downloadgentoo-57147887.tar.gz
gentoo-57147887.tar.bz2
gentoo-57147887.zip
sci-geosciences/osmctools: new package
Fast OpenStreetMap data tools: * osmassignpoly * osmchange - updates an .osm file using one or more .osc files * osmconvert - reads and converts OSM data to the selected output file format * osmfilter - filters OSM data * osmgeobase * osmposition * osmrelpoly * osmupdate - cares about updating an .osm, .o5m or .pbf file * pbftoosm - converts .pbf file into .osm XML format Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--sci-geosciences/osmctools/Manifest1
-rw-r--r--sci-geosciences/osmctools/metadata.xml20
-rw-r--r--sci-geosciences/osmctools/osmctools-0.4_p20200520.ebuild26
3 files changed, 47 insertions, 0 deletions
diff --git a/sci-geosciences/osmctools/Manifest b/sci-geosciences/osmctools/Manifest
new file mode 100644
index 000000000000..5d3232efbd6e
--- /dev/null
+++ b/sci-geosciences/osmctools/Manifest
@@ -0,0 +1 @@
+DIST osmctools-0.4_p20200520.tar.gz 347932 BLAKE2B 33a4bccf15addd42f520c9ee996e1b1eedab7fa1dc4ddc3e4974f8da7b50eb623bd456dedabd694c110bcec494c007aad9d4c6a3ac0404dcc19bf269a2067e33 SHA512 533137524ca788aeda3844112df0e80b996aed7dc79157686c6a882e3e83d49d413201fe8e85534b531d4e4a960296b3f2dd15121464391398c9d07a988adc19
diff --git a/sci-geosciences/osmctools/metadata.xml b/sci-geosciences/osmctools/metadata.xml
new file mode 100644
index 000000000000..1562924bb2e1
--- /dev/null
+++ b/sci-geosciences/osmctools/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ Fast OpenStreetMap data tools:
+ * osmassignpoly
+ * osmchange - updates an .osm file using one or more .osc files
+ * osmconvert - reads and converts OSM data to the selected output file format
+ * osmfilter - filters OSM data
+ * osmgeobase
+ * osmposition
+ * osmrelpoly
+ * osmupdate - cares about updating an .osm, .o5m or .pbf file
+ * pbftoosm - converts .pbf file into .osm XML format
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-geosciences/osmctools/osmctools-0.4_p20200520.ebuild b/sci-geosciences/osmctools/osmctools-0.4_p20200520.ebuild
new file mode 100644
index 000000000000..fb444b3e3426
--- /dev/null
+++ b/sci-geosciences/osmctools/osmctools-0.4_p20200520.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+EGIT_COMMIT="7154bde469f9b4f3f54ef82a8fa41e1592bb5693"
+
+DESCRIPTION="Fast OpenStreetMap data tools"
+HOMEPAGE="https://github.com/ramunasd/osmctools"
+SRC_URI="https://github.com/ramunasd/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}