summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-03 14:25:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-03 16:50:34 +0200
commit571836094e450754dc0ddd8f68ac8cee39898d0e (patch)
treef678e80ef183406dd0a0af82dc32d13ea8ad96a7
parentdev-lang/rust-bin: add cpu_flags_x86_sse2 to REQUIRED_USE (diff)
downloadgentoo-57183609.tar.gz
gentoo-57183609.tar.bz2
gentoo-57183609.zip
media-libs/liblrdf: 0.6.1 version bump
Bug: https://bugs.gentoo.org/470242 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
-rw-r--r--media-libs/liblrdf/Manifest1
-rw-r--r--media-libs/liblrdf/liblrdf-0.6.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/liblrdf/Manifest b/media-libs/liblrdf/Manifest
index 67e01b831f57..64c1ba5ddc65 100644
--- a/media-libs/liblrdf/Manifest
+++ b/media-libs/liblrdf/Manifest
@@ -1 +1,2 @@
DIST liblrdf-0.5.0.tar.gz 283109 BLAKE2B 057b9fcd5fac28624a7d2a2c9da71bc298fe94a11646cf33f3ac3337959ecb4dbe637ecd9e7e889a6761c38c22c32f11a83b114ea53eec4305ff38f684fdb69c SHA512 d3bd4d83fb1e53f93817bcfe30aec74f74e46dd98f1d573b7d123ee0cdf3162b27a24ffc8430f71b1616d9ba9af7c88b1b625e7459b30f3941804b56c5cc0cd3
+DIST liblrdf-0.6.1.tar.gz 43878 BLAKE2B 98ae1a900ac4f5517fb027984f4bb40c02cd290ce4ed26a0f8207c353946914d5c984e34df85349def08ef34002028f61649f5370f8b36d663160843db9bd13e SHA512 7732813eec704aef984d056de254e4fa049fdd0a7444b6a88f75f012afe9c587cbd1295f027c77361fa42bc097cdce9d9cabdba6b86e99a3c14805d84258df1c
diff --git a/media-libs/liblrdf/liblrdf-0.6.1.ebuild b/media-libs/liblrdf/liblrdf-0.6.1.ebuild
new file mode 100644
index 000000000000..6d22fc1c2bcb
--- /dev/null
+++ b/media-libs/liblrdf/liblrdf-0.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library for manipulation of RDF files in LADSPA plugins"
+HOMEPAGE="https://github.com/swh/LRDF"
+SRC_URI="https://github.com/swh/LRDF/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="static-libs"
+
+RDEPEND="
+ media-libs/ladspa-sdk
+ media-libs/raptor:2
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+S="${WORKDIR}/LRDF-${PV}"
+
+src_prepare() {
+ default
+ sed -i -e 's:usr/local:usr:' examples/{instances,remove}_test.c || die #392221
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_test() {
+ has_version media-plugins/swh-plugins && default #392221
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}