summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-02-26 14:57:02 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-02-26 14:57:58 +0100
commit571da4a2bc45467e775491ef7fdb88657be1b41d (patch)
tree8156a0f09946d6c61d37a07d62e2bfc96aec03b7
parentsys-kernel/rt-sources: Add Karl Linden as Proxy Maintainer (diff)
downloadgentoo-571da4a2bc45467e775491ef7fdb88657be1b41d.tar.gz
gentoo-571da4a2bc45467e775491ef7fdb88657be1b41d.tar.bz2
gentoo-571da4a2bc45467e775491ef7fdb88657be1b41d.zip
app-text/libebook: Fix build with boost-1.59, bug 574764
Package-Manager: portage-2.2.27
-rw-r--r--app-text/libebook/files/libebook-0.1.2-boost-1.59-makefile.patch10
-rw-r--r--app-text/libebook/libebook-0.1.2-r1.ebuild57
2 files changed, 67 insertions, 0 deletions
diff --git a/app-text/libebook/files/libebook-0.1.2-boost-1.59-makefile.patch b/app-text/libebook/files/libebook-0.1.2-boost-1.59-makefile.patch
new file mode 100644
index 000000000000..9869b308c73c
--- /dev/null
+++ b/app-text/libebook/files/libebook-0.1.2-boost-1.59-makefile.patch
@@ -0,0 +1,10 @@
+--- a/src/lib/Makefile.am
++++ b/src/lib/Makefile.am
+@@ -64,6 +64,7 @@
+ libe_book_@EBOOK_MAJOR_VERSION@_@EBOOK_MINOR_VERSION@_la_SOURCES = \
+ EBOOKDocument.cpp
+
++libe_book_internal_la_CPPFLAGS = -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED
+ libe_book_internal_la_SOURCES = \
+ EBOOKBitStream.cpp \
+ EBOOKBitStream.h \
diff --git a/app-text/libebook/libebook-0.1.2-r1.ebuild b/app-text/libebook/libebook-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..9ee438db230f
--- /dev/null
+++ b/app-text/libebook/libebook-0.1.2-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="libe-book"
+MY_P="${MY_PN}-${PV}"
+
+inherit eutils autotools
+
+DESCRIPTION="Library parsing various ebook formats"
+HOMEPAGE="http://www.sourceforge.net/projects/libebook/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost:=
+ dev-util/gperf
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.59-makefile.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable test tests) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}