summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-08 20:07:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-08 21:08:13 +0200
commit5757a45d9cb9bd75bcf8d843f7847235aed0ca33 (patch)
tree14b83d4259a8b2bc39f6cc22ab09198e7baa45cf
parentapp-misc/byobu: remove old (diff)
downloadgentoo-5757a45d9cb9bd75bcf8d843f7847235aed0ca33.tar.gz
gentoo-5757a45d9cb9bd75bcf8d843f7847235aed0ca33.tar.bz2
gentoo-5757a45d9cb9bd75bcf8d843f7847235aed0ca33.zip
app-text/libwpg: 0.3.2 version bump
Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--app-text/libwpg/Manifest1
-rw-r--r--app-text/libwpg/libwpg-0.3.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/libwpg/Manifest b/app-text/libwpg/Manifest
index 97b268172f71..7fdd10343276 100644
--- a/app-text/libwpg/Manifest
+++ b/app-text/libwpg/Manifest
@@ -1 +1,2 @@
DIST libwpg-0.3.1.tar.xz 316576 SHA256 620d888c10d7e1127d5123ff0065f1b62b86b91bac27d8ae10dcfbdb6bf4278f SHA512 5222609510857d32250e25b1108ecf4c0ce1e58fba280b7c15d400bc8963112adaa9fffa3c21087d4984ec52176d69b30bfc9460ffef978d6b0d7ccc400063b2 WHIRLPOOL c35c51b5098757a0de9a1288d185708775d4ecc2b69ad76e818df5308ec1cbcb870552d45edfe011f65aff141e12656bf98a8ce5207fc0f12ecbc9c705afb3e2
+DIST libwpg-0.3.2.tar.xz 326840 SHA256 57faf1ab97d63d57383ac5d7875e992a3d190436732f4083310c0471e72f8c33 SHA512 f3f76a17056274b2dfd11ce4eb451411d8458b00b3f7be4fae0a932a382f247adbaae1f4f8f6005e7b84f063e415ef5ab609015ba32f779c6ab2f0404b275f3f WHIRLPOOL 492ebc20d136ccd2525c9e1b1ac5613dc6dc74df140c1e190defa22fa5fdb2c04765c5121764c0452087ac9038446384634e61d04512046c22784c523791d911
diff --git a/app-text/libwpg/libwpg-0.3.2.ebuild b/app-text/libwpg/libwpg-0.3.2.ebuild
new file mode 100644
index 000000000000..c6a8e938c204
--- /dev/null
+++ b/app-text/libwpg/libwpg-0.3.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit alternatives
+
+DESCRIPTION="C++ library to read and parse graphics in WPG"
+HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.10[tools]
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ --program-suffix=-${SLOT} \
+ $(use_with doc docs) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
+}
+
+pkg_postrm() {
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
+}