summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-07 04:13:18 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-07 04:58:52 +0100
commit5766955f5d8c448e4136be367733427195305c25 (patch)
tree0aa501fd9baae01d4a1ba66a7ced161591b9adc1
parentdev-python/boto3: Bump to 1.33.9 (diff)
downloadgentoo-5766955f.tar.gz
gentoo-5766955f.tar.bz2
gentoo-5766955f.zip
app-admin/awscli: Bump to 1.31.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.31.9.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index bcfc5188c882..4f684f4d2118 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.30.6.gh.tar.gz 2596217 BLAKE2B 3b4cbd540ede2826d212233e76a4431f09
DIST aws-cli-1.31.6.gh.tar.gz 2605365 BLAKE2B 30e7789a2a4f47b3b4dce9fb3c8083d56ebec8501d66fa03e34309c1c9e0c6302ce79c044fb1aecd879f2784443db5a9927bfb1c22e94883709600f0e1c538b4 SHA512 5da1be164d4e52b255093c0685b4add43a21b2f0259a6ad9b6e6bc1c7bbb17e1ee0db0f6b29ff0227b301d7f66e1d63b3d92047ccef5578b9de6b5579319be6c
DIST aws-cli-1.31.7.gh.tar.gz 2605660 BLAKE2B 7b7dbdf2179964f6d23e0ad09c2ec7f45c07f15986c9761c9bca3b2d3dc685a3eee32fcd2108d81e2c918386120f6307918671c16b602a4236adc6873d78be06 SHA512 defbb2d861ee3ca5f0cab70e2a963b64e5dcfce1eb251b6685888d89adfe61a1bcdd8e428444bc37f0a266e9e602204028af6ba292de995fd0ae3956a6857364
DIST aws-cli-1.31.8.gh.tar.gz 2605946 BLAKE2B 847e30da21c149819c05af1a08aa8a38dd390fbeab4e09ca890b1fc56dc6211b972b567d53834f816362479b87d40ee0815167e45b3dc6eefbb93e6d7a5b9ce4 SHA512 89b5935bf29b679de1031e22f302fa74d9fd8fd60c3c9bf7458e2fa708d8fb8072d439f6c5b0e987be5d4e519820fb4d230bdc6d72795a462ccd98fb17f2bd86
+DIST aws-cli-1.31.9.gh.tar.gz 2606393 BLAKE2B 3886b5444f784c85f1d8ef5b7bc9bc4aabd1ee2549b3a889780dc79eb8d4aa9b9b75d71f8ec18587d068d3f221c76b482f344a0a4f2504126820021ad3afeb21 SHA512 204ae4789d2272a1cc5c2a64607d577366c0c76d64fc619125428d96aec37e0cb510f1ecb523cfaebecd3e40e7115f1ebfe38fcc9eb1d142a0695d2a0ca9a2be
diff --git a/app-admin/awscli/awscli-1.31.9.ebuild b/app-admin/awscli/awscli-1.31.9.ebuild
new file mode 100644
index 000000000000..18db68f93233
--- /dev/null
+++ b/app-admin/awscli/awscli-1.31.9.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.8.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}