summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-01-21 00:46:11 +0200
committerMart Raudsepp <leio@gentoo.org>2024-01-21 01:31:03 +0200
commit57769552c12997adb7102ec324c4d7881061e31c (patch)
tree20e992ba3d572f436a1e2334cc1b34c1f3f8c345
parentgui-libs/gtk: add 4.12.5 (diff)
downloadgentoo-57769552c12997adb7102ec324c4d7881061e31c.tar.gz
gentoo-57769552c12997adb7102ec324c4d7881061e31c.tar.bz2
gentoo-57769552c12997adb7102ec324c4d7881061e31c.zip
x11-libs/gtk+: add 3.24.40
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--x11-libs/gtk+/Manifest1
-rw-r--r--x11-libs/gtk+/files/3.24.40-gdkscreen-x11-fixes.patch50
-rw-r--r--x11-libs/gtk+/files/3.24.40-test-casts-gcc14.patch82
-rw-r--r--x11-libs/gtk+/gtk+-3.24.40.ebuild203
4 files changed, 336 insertions, 0 deletions
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index e1899ef12489..ac3740caa7dd 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -2,3 +2,4 @@ DIST gtk+-2.24.33.tar.xz 12661828 BLAKE2B f3488b220aaee54bf36fa77e2112d060152e57
DIST gtk+-3.24.35.tar.xz 17913328 BLAKE2B 3beea3cbda7247357238ad133c951e69d5670d68e06efb4de09fae7141b141f4eb17a8c79661cab928a3db427f7b32b518875d0951254941e76b1a7aab60e34f SHA512 3a1ec35756fe12f5be3cfe33ef332d583690458327572e69bffad8b4095059d2a744a4a53b2fd31bab5da2ca7b41a2a38fbbd8ba541a45fa8cc0d00eae005ade
DIST gtk+-3.24.38.tar.xz 12398104 BLAKE2B d24e794025d09b01c215ffcc60382f1bb74214b80fbc019bc0fc2a01bd90673c5a9e94b07b6ec981e9b28caf42b8e98032dd8150ac44a9bcab22bae83445685e SHA512 e99ec10959191b55013fce37e83f0e85bf36597db101e324081479792a2047d032cf0d213d69c02eeb4b7cd6d56d6489b7b2a60904b2bd7af23ea1b9c5a79528
DIST gtk+-3.24.39.tar.xz 12464680 BLAKE2B 9d0d5814369211c1d60cc81de45a5dfd6ea9fc64d24948abf304e0ad1ae606d9887fc4e5ddccbfab4fb1ccc3c5bb54b453f28899cbdef4e4e885a7f041a6c70f SHA512 8ec3db3544805b51fffaa415029b126761ba0a11b68c67cea80fe001e77878abf4d4719d5d002109f8546409c0caf892ea6d7aa792f8d5d97dc4139668f0451f
+DIST gtk+-3.24.40.tar.xz 13189496 BLAKE2B 6c098e879264051e61a639c327687ead6459c79f226aed5634e4b912d066913a006a5555483e3fab92352dc355fac6af04b910f76b909e99e33d79a03a8dde1f SHA512 21fac23b6375c2e545128e60d4e39f7ee9516a824e4a1834a318af5f2a9f125a8a8572a83bf94b4c179a16c66b6a913e74574ccf2e810301f1a593006a1980c7
diff --git a/x11-libs/gtk+/files/3.24.40-gdkscreen-x11-fixes.patch b/x11-libs/gtk+/files/3.24.40-gdkscreen-x11-fixes.patch
new file mode 100644
index 000000000000..e096e920eaee
--- /dev/null
+++ b/x11-libs/gtk+/files/3.24.40-gdkscreen-x11-fixes.patch
@@ -0,0 +1,50 @@
+From 6880ac90a0211095cfea753316e002bd668a4e92 Mon Sep 17 00:00:00 2001
+From: Michael Wyraz <mw@brick4u.de>
+Date: Fri, 19 Jan 2024 19:15:52 +0100
+Subject: [PATCH 1/2] don't free monitor->name twice (fixes #6345)
+
+---
+ gdk/x11/gdkscreen-x11.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/gdk/x11/gdkscreen-x11.c b/gdk/x11/gdkscreen-x11.c
+index f54bf51d04..4ac3167b30 100644
+--- a/gdk/x11/gdkscreen-x11.c
++++ b/gdk/x11/gdkscreen-x11.c
+@@ -922,7 +922,6 @@ init_randr13 (GdkScreen *screen, gboolean *changed)
+ g_object_ref (monitor);
+ g_ptr_array_remove (x11_display->monitors, monitor);
+ gdk_display_monitor_removed (display, GDK_MONITOR (monitor));
+- free (monitor->name);
+ g_object_unref (monitor);
+ *changed = TRUE;
+ }
+--
+2.43.0
+
+
+From ba58b3a23df4213e17a80816c7687a59e104769d Mon Sep 17 00:00:00 2001
+From: Michael Wyraz <mw@brick4u.de>
+Date: Fri, 19 Jan 2024 22:20:02 +0100
+Subject: [PATCH 2/2] Fix for #6342
+
+---
+ gdk/x11/gdkscreen-x11.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gdk/x11/gdkscreen-x11.c b/gdk/x11/gdkscreen-x11.c
+index 4ac3167b30..6207b5f443 100644
+--- a/gdk/x11/gdkscreen-x11.c
++++ b/gdk/x11/gdkscreen-x11.c
+@@ -851,7 +851,7 @@ init_randr13 (GdkScreen *screen, gboolean *changed)
+ monitor = g_object_new (gdk_x11_monitor_get_type (),
+ "display", display,
+ NULL);
+- monitor->name = g_steal_pointer (&name);
++ monitor->name = g_strdup (name);
+ monitor->output = output;
+ monitor->add = TRUE;
+ g_ptr_array_add (x11_display->monitors, monitor);
+--
+2.43.0
+
diff --git a/x11-libs/gtk+/files/3.24.40-test-casts-gcc14.patch b/x11-libs/gtk+/files/3.24.40-test-casts-gcc14.patch
new file mode 100644
index 000000000000..aadbd7be0b7c
--- /dev/null
+++ b/x11-libs/gtk+/files/3.24.40-test-casts-gcc14.patch
@@ -0,0 +1,82 @@
+From 76bc2a57136fd6cf0374fa3f86a7ba646b779803 Mon Sep 17 00:00:00 2001
+From: David King <amigadave@amigadave.com>
+Date: Fri, 19 Jan 2024 10:41:33 +0000
+Subject: [PATCH 1/2] tests: Add GdkEvent casts in testinput
+
+---
+ tests/testinput.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/tests/testinput.c b/tests/testinput.c
+index b68552a428..3d4d7f6f87 100644
+--- a/tests/testinput.c
++++ b/tests/testinput.c
+@@ -194,7 +194,7 @@ button_press_event (GtkWidget *widget, GdkEventButton *event)
+
+ print_axes (event->device, event->axes);
+ gdk_event_get_axis ((GdkEvent *)event, GDK_AXIS_PRESSURE, &pressure);
+- draw_brush (widget, gdk_device_get_source (gdk_event_get_source_device (event)),
++ draw_brush (widget, gdk_device_get_source (gdk_event_get_source_device ((GdkEvent *)event)),
+ event->x, event->y, pressure);
+
+ motion_time = event->time;
+@@ -239,10 +239,10 @@ motion_notify_event (GtkWidget *widget, GdkEventMotion *event)
+ gdk_device_get_axis (event->device, events[i]->axes, GDK_AXIS_X, &x);
+ gdk_device_get_axis (event->device, events[i]->axes, GDK_AXIS_Y, &y);
+ gdk_device_get_axis (event->device, events[i]->axes, GDK_AXIS_PRESSURE, &pressure);
+- draw_brush (widget, gdk_device_get_source (gdk_event_get_source_device (event)),
++ draw_brush (widget, gdk_device_get_source (gdk_event_get_source_device ((GdkEvent *)event)),
+ x, y, pressure);
+
+- print_axes (gdk_event_get_source_device (event), events[i]->axes);
++ print_axes (gdk_event_get_source_device ((GdkEvent *)event), events[i]->axes);
+ }
+ gdk_device_free_history (events, n_events);
+ }
+@@ -252,7 +252,7 @@ motion_notify_event (GtkWidget *widget, GdkEventMotion *event)
+
+ gdk_event_get_axis ((GdkEvent *)event, GDK_AXIS_PRESSURE, &pressure);
+
+- draw_brush (widget, gdk_device_get_source (gdk_event_get_source_device (event)),
++ draw_brush (widget, gdk_device_get_source (gdk_event_get_source_device ((GdkEvent *)event)),
+ event->x, event->y, pressure);
+ }
+ motion_time = event->time;
+--
+2.43.0
+
+
+From 05a12b1c5f8eecc621a7135eb313d6bfe6ccdc3b Mon Sep 17 00:00:00 2001
+From: David King <amigadave@amigadave.com>
+Date: Fri, 19 Jan 2024 11:04:37 +0000
+Subject: [PATCH 2/2] testsuite: Fix casts in reftests
+
+---
+ testsuite/reftests/gtk-reftest.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/testsuite/reftests/gtk-reftest.c b/testsuite/reftests/gtk-reftest.c
+index 1a51a9756b..88d8a849ca 100644
+--- a/testsuite/reftests/gtk-reftest.c
++++ b/testsuite/reftests/gtk-reftest.c
+@@ -381,7 +381,7 @@ enforce_default_settings (void)
+
+ klass = g_type_class_ref (G_OBJECT_TYPE (settings));
+
+- pspecs = g_object_class_list_properties (klass, &n_pspecs);
++ pspecs = g_object_class_list_properties (G_OBJECT_CLASS (klass), &n_pspecs);
+ for (i = 0; i < n_pspecs; i++)
+ {
+ GParamSpec *pspec = pspecs[i];
+@@ -394,7 +394,7 @@ enforce_default_settings (void)
+ continue;
+
+ value = g_param_spec_get_default_value (pspec);
+- g_object_set_property (settings, pspec->name, value);
++ g_object_set_property (G_OBJECT (settings), pspec->name, value);
+ }
+
+ g_free (pspecs);
+--
+2.43.0
+
diff --git a/x11-libs/gtk+/gtk+-3.24.40.ebuild b/x11-libs/gtk+/gtk+-3.24.40.ebuild
new file mode 100644
index 000000000000..3b353a3e007f
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-3.24.40.ebuild
@@ -0,0 +1,203 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson-multilib multilib toolchain-funcs virtualx
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="https://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="3"
+IUSE="aqua broadway cloudproviders colord cups examples gtk-doc +introspection sysprof test vim-syntax wayland +X xinerama"
+REQUIRED_USE="
+ || ( aqua wayland X )
+ test? ( X )
+ xinerama? ( X )
+"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/fribidi-0.19.7[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.57.2:2[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.2.0:=
+ >=media-libs/libepoxy-1.4[X(+)?,egl(+),${MULTILIB_USEDEP}]
+ virtual/libintl[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.14[aqua?,glib,svg(+),X?,${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.30:2[introspection?,${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.44.0[introspection?,${MULTILIB_USEDEP}]
+ x11-misc/shared-mime-info
+
+ cloudproviders? ( net-libs/libcloudproviders[${MULTILIB_USEDEP}] )
+ colord? ( >=x11-misc/colord-0.1.9:0=[${MULTILIB_USEDEP}] )
+ cups? ( >=net-print/cups-2.0[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.39:= )
+ sysprof? ( >=dev-util/sysprof-capture-3.33.2:3[${MULTILIB_USEDEP}] )
+ wayland? (
+ >=dev-libs/wayland-1.14.91[${MULTILIB_USEDEP}]
+ >=dev-libs/wayland-protocols-1.32
+ media-libs/mesa[wayland,${MULTILIB_USEDEP}]
+ >=x11-libs/libxkbcommon-0.2[${MULTILIB_USEDEP}]
+ )
+ X? (
+ media-libs/libglvnd[X(+),${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.8[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.5[${MULTILIB_USEDEP}]
+ xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ X? ( x11-base/xorg-proto )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-update-icon-cache-3
+"
+# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
+PDEPEND="
+ gnome-base/librsvg[${MULTILIB_USEDEP}]
+ >=x11-themes/adwaita-icon-theme-3.14
+ vim-syntax? ( app-vim/gtk-syntax )
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/gobject-introspection-common
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.48
+ dev-util/glib-utils
+ >=dev-build/gtk-doc-am-1.20
+ wayland? ( dev-util/wayland-scanner )
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+ x11-libs/gdk-pixbuf:2
+ gtk-doc? (
+ app-text/docbook-xml-dtd:4.3
+ >=dev-util/gtk-doc-1.20
+ )
+ test? ( sys-apps/dbus )
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/gtk-query-immodules-3.0$(get_exeext)
+)
+
+PATCHES=(
+ # Upstream gtk-3-24 branch regression fixes and tests compile compat for modern C
+ "${FILESDIR}"/${PV}-gdkscreen-x11-fixes.patch
+ "${FILESDIR}"/${PV}-test-casts-gcc14.patch
+ # gtk-update-icon-cache is installed by dev-util/gtk-update-icon-cache
+ "${FILESDIR}"/${PN}-3.24.36-update-icon-cache.patch
+)
+
+src_prepare() {
+ default
+
+ # The border-image-excess-size.ui test is known to fail on big-endian platforms
+ # See https://gitlab.gnome.org/GNOME/gtk/-/issues/5904
+ if [[ $(tc-endian) == big ]]; then
+ sed -i \
+ -e "/border-image-excess-size.ui/d" \
+ -e "/^xfails =/a 'border-image-excess-size.ui'," \
+ testsuite/reftests/meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_use aqua quartz_backend)
+ $(meson_use broadway broadway_backend)
+ $(meson_use cloudproviders)
+ $(meson_use examples demos)
+ $(meson_use examples)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ $(meson_native_use_bool introspection)
+ $(meson_use sysprof profiler)
+ $(meson_use wayland wayland_backend)
+ $(meson_use X x11_backend)
+ -Dcolord=$(usex colord yes no)
+ -Dprint_backends=$(usex cups cups,file,lpr file,lpr)
+ -Dxinerama=$(usex xinerama yes no)
+ # Include backend immodules into gtk itself, to avoid problems like
+ # https://gitlab.gnome.org/GNOME/gnome-shell/issues/109 from a
+ # user overridden GTK_IM_MODULE envvar
+ -Dbuiltin_immodules=backend
+ -Dman=true
+ $(meson_use test tests)
+ -Dtracker3=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}" --timeout-multiplier 4 || die
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ insinto /etc/gtk-3.0
+ doins "${FILESDIR}"/settings.ini
+ # Skip README.win32.md that would get installed by default
+ DOCS=( NEWS README.md )
+ einstalldocs
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+
+ multilib_pkg_preinst() {
+ # Make immodules.cache belongs to gtk+ alone
+ local cache="/usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
+
+ if [[ -e ${EROOT}${cache} ]]; then
+ cp "${EROOT}${cache}" "${ED}${cache}" || die
+ else
+ touch "${ED}${cache}" || die
+ fi
+ }
+ multilib_parallel_foreach_abi multilib_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_query_immodules_gtk3 \
+ || die "Update immodules cache failed (for ${ABI})"
+ }
+ multilib_parallel_foreach_abi multilib_pkg_postinst
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your settings.ini file."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ if [[ -z ${REPLACED_BY_VERSION} ]]; then
+ multilib_pkg_postrm() {
+ rm -f "${EROOT}/usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+ fi
+}