summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2022-07-20 13:57:23 +0200
committerSam James <sam@gentoo.org>2022-08-23 06:34:19 +0100
commit577e733cd936ecf7c734de289cc731308a41db94 (patch)
treeaffa7a844e72a6ed7870a7b9d7664f56b2a24212
parentdev-util/scap-driver: new package, replacement for sysdig-kmod (diff)
downloadgentoo-577e733c.tar.gz
gentoo-577e733c.tar.bz2
gentoo-577e733c.zip
dev-util/sysdig: bump to 0.29.3
Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/26496 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/sysdig/Manifest2
-rw-r--r--dev-util/sysdig/metadata.xml9
-rw-r--r--dev-util/sysdig/sysdig-0.29.3.ebuild88
3 files changed, 98 insertions, 1 deletions
diff --git a/dev-util/sysdig/Manifest b/dev-util/sysdig/Manifest
index cc1b76c77570..9262fd7968f3 100644
--- a/dev-util/sysdig/Manifest
+++ b/dev-util/sysdig/Manifest
@@ -1 +1,3 @@
+DIST falcosecurity-libs-e5c53d648f3c4694385bbe488e7d47eaa36c229a.tar.gz 816972 BLAKE2B b47ae6a7677935500ebdab8aea7f4c49ef50b7175ec097e7213a1f041ac2b5aa642379924927ec12c84271016e9ab9d191c0c1d4ffacd6ade58b7a03c37f9221 SHA512 65e5916e5f9507fd867a5e9ba3b2670a1b73b7672a22479d3019e948a52ad74441d7e2ce1c74ebd0fdbd1ce66808efa49f285bd5180bceae9d4e6730a60787ce
DIST sysdig-0.27.1.tar.gz 936415 BLAKE2B f4c15e3a2d4b974c5eafc8374f927dd82f123c05cc1976d04b08e77e1a7c0ff53f37c4e2c0022b7073fcc936310daf76ca3c3611141799ae4f51991bc6f3a0a3 SHA512 690f012c7db0a75ec2eb78fae17aae0f422aa1db0d4c2b15c4a09153fd2f60bd3c00d62238976fdcff2a906d87b2e34b81d02c0c78ad2684a1d6016a9988eb08
+DIST sysdig-0.29.3.tar.gz 306984 BLAKE2B 51e9a0a085fa91d65963fd33e00b139d97d22b551de8ca85e48b4af73991897378970dfde54754a970e79300f06a54bad1d9c8fdfdb44f24150d0b21077e423f SHA512 1dbe1195f245921c671ed2343325aee79fd0cde34681b9cab445135662d3ed7c84884e46b2270c0e868b5de1a3f2800b84e8bf9fcf0dfe581dd17e2e633f46d8
diff --git a/dev-util/sysdig/metadata.xml b/dev-util/sysdig/metadata.xml
index 8e4769903018..c16f8ef41665 100644
--- a/dev-util/sysdig/metadata.xml
+++ b/dev-util/sysdig/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>holger@applied-asynchrony.com</email>
+ <name>Holger Hoffstätte</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<use>
<flag name="modules">Build kernel modules needed for tracing local
events. Disable this only if you intend to use sysdig purely
diff --git a/dev-util/sysdig/sysdig-0.29.3.ebuild b/dev-util/sysdig/sysdig-0.29.3.ebuild
new file mode 100644
index 000000000000..2c0745f73303
--- /dev/null
+++ b/dev-util/sysdig/sysdig-0.29.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( luajit )
+
+inherit bash-completion-r1 cmake lua-single
+
+DESCRIPTION="A system exploration and troubleshooting tool"
+HOMEPAGE="https://sysdig.com/"
+
+# For now we need to bump this version of falcosecurity/libs manually;
+# check the used git revision in <src>/cmake/modules/falcosecurity-libs.cmake
+LIBS_COMMIT="e5c53d648f3c4694385bbe488e7d47eaa36c229a"
+
+SRC_URI="https://github.com/draios/sysdig/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/falcosecurity/libs/archive/${LIBS_COMMIT}.tar.gz -> falcosecurity-libs-${LIBS_COMMIT}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+modules"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}
+ app-misc/jq
+ dev-cpp/tbb:=
+ dev-cpp/yaml-cpp:=
+ dev-libs/libb64:=
+ dev-libs/openssl:=
+ dev-libs/protobuf:=
+ net-dns/c-ares:=
+ net-libs/grpc:=
+ net-misc/curl
+ sys-libs/ncurses:=
+ sys-libs/zlib:="
+
+DEPEND="${RDEPEND}
+ dev-cpp/nlohmann_json
+ dev-cpp/valijson
+ virtual/os-headers"
+
+# for now pin the driver to the same ebuild version
+PDEPEND="modules? ( =dev-util/scap-driver-${PV}* )"
+
+src_prepare() {
+ sed -i -e 's:-ggdb::' CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # don't build driver
+ -DBUILD_DRIVER=OFF
+
+ # libscap examples are not installed or really useful
+ -DBUILD_LIBSCAP_EXAMPLES=OFF
+
+ # point to the falcosecurity-libs tree
+ -DFALCOSECURITY_LIBS_SOURCE_DIR="${WORKDIR}"/libs-${LIBS_COMMIT}
+
+ # explicitly set version
+ -DSYSDIG_VERSION=${PV}
+
+ # unbundle the deps
+ -DUSE_BUNDLED_DEPS=OFF
+
+ # add valijson include path to prevent downloading
+ -DVALIJSON_INCLUDE="${ESYSROOT}"/usr/include
+
+ # enable chisels
+ -DWITH_CHISEL=ON
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # remove driver headers
+ rm -r "${ED}"/usr/src || die
+
+ # move bashcomp to the proper location
+ dobashcomp "${ED}"/usr/etc/bash_completion.d/sysdig || die
+ rm -r "${ED}"/usr/etc || die
+}