summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-28 00:56:13 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-28 01:18:35 +0200
commit57aa47e9f505a9641c759d8da5a941287bfe1038 (patch)
tree7d3bcabd45766852d74745f06a8e3001763c4800
parentdev-python/hypothesis: Bump to 6.13.7 (diff)
downloadgentoo-57aa47e9.tar.gz
gentoo-57aa47e9.tar.bz2
gentoo-57aa47e9.zip
dev-python/cliff: Bump to 3.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-3.8.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index cb88603c1ba3..1c8dcab3d55e 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1 +1,2 @@
DIST cliff-3.7.0.tar.gz 81853 BLAKE2B aab3ad056c13232978e93b380d9d0d48748778f403b4200c09f92bcedc6c2806213d81612aa453277e2c99acc5959ad666ac888d4a0726f50a5c0f04be0e9fdd SHA512 d3cf3ecc6778bbc676e47ebfcbc6be4ee120dd864684da58e476f52d021b5932bf9361ce2aa6a8ee4d68845ba79ec7a9174cfa7f21fa3fa16a945b96c968cc26
+DIST cliff-3.8.0.tar.gz 81862 BLAKE2B 3a8219f822fdf14e1de56204b0f536a92d27be5a99fb628f3aed5b569a1e703d4711bdded28fa42c0692316454847ba3338baac8efae873540652e46d155227a SHA512 002e3ddfb254c5369582cc28572856a8b4ad05d598a7f8aa690add69f49cabb12ef2ef17b6c1553792aaee785b7c1703b05dd9d4889271cd5eba5629fad3d09b
diff --git a/dev-python/cliff/cliff-3.8.0.ebuild b/dev-python/cliff/cliff-3.8.0.ebuild
new file mode 100644
index 000000000000..fab20af93f82
--- /dev/null
+++ b/dev-python/cliff/cliff-3.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+# TODO: revert to rdepend once this is merged
+# https://github.com/openstack/cliff/pull/3
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/openstack/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest