summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-11-16 13:11:53 -0800
committerMatt Turner <mattst88@gentoo.org>2018-11-16 13:12:45 -0800
commit57b176c43bcebd73bd41786667d3f81894591ffe (patch)
tree7854c4dff7b406db155cfeaee0fb54b074e12019
parentmedia-video/makemkv: Add missing ccextractor dependency with symlink (diff)
downloadgentoo-57b176c4.tar.gz
gentoo-57b176c4.tar.bz2
gentoo-57b176c4.zip
media-libs/mesa: Make python_check_deps() unconditional
mako is unconditionally required. Noticed by Arfrever. Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/mesa/mesa-18.3.0_rc3.ebuild4
-rw-r--r--media-libs/mesa/mesa-9999.ebuild4
2 files changed, 2 insertions, 6 deletions
diff --git a/media-libs/mesa/mesa-18.3.0_rc3.ebuild b/media-libs/mesa/mesa-18.3.0_rc3.ebuild
index 2cbc171b7a7e..c65792857090 100644
--- a/media-libs/mesa/mesa-18.3.0_rc3.ebuild
+++ b/media-libs/mesa/mesa-18.3.0_rc3.ebuild
@@ -301,9 +301,7 @@ pkg_pretend() {
}
python_check_deps() {
- if use test; then
- has_version ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]"
- fi
+ has_version ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]"
}
pkg_setup() {
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index ab18ab72df4b..bbc496e71565 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -301,9 +301,7 @@ pkg_pretend() {
}
python_check_deps() {
- if use test; then
- has_version ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]"
- fi
+ has_version ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]"
}
pkg_setup() {