summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-24 10:56:25 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-24 10:57:55 +0100
commit57b8b219ded860cbb2a9857fd172878442f609ba (patch)
tree31232541a9df48b91c73a241395c8deca05a447e
parentwww-client/chromium: stable channel bump to 92.0.4515.107 (diff)
downloadgentoo-57b8b219ded860cbb2a9857fd172878442f609ba.tar.gz
gentoo-57b8b219ded860cbb2a9857fd172878442f609ba.tar.bz2
gentoo-57b8b219ded860cbb2a9857fd172878442f609ba.zip
sys-libs/libstdc++-v3: bump up to EAPI=8
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-libs/libstdc++-v3/Manifest1
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r4.ebuild201
2 files changed, 202 insertions, 0 deletions
diff --git a/sys-libs/libstdc++-v3/Manifest b/sys-libs/libstdc++-v3/Manifest
index 816a3df55a05..584ab64a4d90 100644
--- a/sys-libs/libstdc++-v3/Manifest
+++ b/sys-libs/libstdc++-v3/Manifest
@@ -1,2 +1,3 @@
DIST gcc-3.3.6-patches-1.10.tar.bz2 53739 BLAKE2B d22772d30c432669299e3e6df350920408c510a241a20e6795dcc680227342a16c3b6d2e477a17d6c49794005b42972ed30b4efe5b2d69398d283f50efdeb459 SHA512 be6cc8fae217f789982e324e0d3ad12d527e43ca4c168bce613397aaf3d86219b125e7b39c2b236638a68112cfee0e06c1b297fead712d92b3923b7195299d0a
+DIST gcc-3.3.6-patches-4.tar.bz2 53437 BLAKE2B 372ff1fcfcfacca43b420d2cda7fccb2ede4917408e1fcceb6c094694de8ae21148fa9c5ab8663cf6fb9ad858e3d0cbb3f20c91020db7b627828403444c2fd66 SHA512 1ff4563956d2f3af1240a14cd1ec126ff75dcf24e1cec39d32a17d6be92b94aeb081605ceb04b138ba905cea8ccbe204dce4b42a02ef55383fcfa91643f73faf
DIST gcc-3.3.6.tar.bz2 23972413 BLAKE2B e7b33edcdbbb13b0be41a41156bf6fb6dcfe4f5ad75c41de86cb37f854be6b7a6a8dda0e65d331461469848cd912e25920e8aa2dcb142cb661731ba571cb5de1 SHA512 576b88e2fa675314a79a85f180684fe5af370c596476a0bf02e33e8ae0e2be838417ea80675ce4194a8213792cf7ada50cae5131149e4b890ab61e0b8d50d0ed
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r4.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r4.ebuild
new file mode 100644
index 000000000000..f120d1011724
--- /dev/null
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r4.ebuild
@@ -0,0 +1,201 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic libtool multilib toolchain-funcs
+
+PATCH_VER="4"
+
+DESCRIPTION="Compatibility package for binaries linked against a pre gcc 3.4 libstdc++"
+HOMEPAGE="https://gcc.gnu.org/libstdc++/"
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-${PV}.tar.bz2
+ https://dev.gentoo.org/~slyfox/distfiles/gcc-${PV}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="multilib nls"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/bison"
+
+transform_known_flags() {
+ declare setting
+
+ # and on x86, we just need to filter the 3.4 specific amd64 -marchs
+ replace-cpu-flags k8 athlon64 opteron x86-64
+
+ # gcc 3.3 doesn't support -march=pentium-m
+ replace-cpu-flags pentium-m pentium3m pentium3
+
+ #GCC 3.3 does not understand G3, G4, G5 on ppc
+ replace-cpu-flags G3 750
+ replace-cpu-flags G4 7400
+ replace-cpu-flags G5 7400
+
+ filter-flags -fdiagnostics-show-option
+}
+
+is_arch_allowed() {
+ i386_processor_table="i386 i486 i586 pentium pentium-mmx winchip-c6 \
+ winchip2 c3 i686 pentiumpro pentium2 pentium3 pentium4 prescott \
+ nocona k6 k6-2 k6-3 athlon athlon-tbird x86-64 athlon-4 athlon-xp \
+ athlon-mp"
+
+ for proc in ${i386_processor_table} ; do
+ [[ "${proc}" == "${1}" ]] && return 0
+ done
+
+ mips_processor_table="mips1 mips2 mips3 mips4 mips32 mips64 r3000 r2000 \
+ r3900 r6000 r4000 vr4100 vr4111 vr4120 vr4300 r4400 r4600 orion \
+ r4650 r8000 vr5000 vr5400 vr5500 4kc 4kp 5kc 20kc sr71000 sb1"
+
+ for proc in ${mips_processor_table} ; do
+ [[ "${proc}" == "${1}" ]] && return 0
+ done
+
+ rs6000_processor_table="common power power2 power3 power4 powerpc \
+ powerpc64 rios rios1 rsc rsc1 rios2 rs64a 401 403 405 505 601 602 \
+ 603 603e ec603e 604 604e 620 630 740 750 7400 7450 8540 801 821 823 \
+ 860"
+
+ for proc in ${rs6000_processor_table} ; do
+ [[ "${proc}" == "${1}" ]] && return 0
+ done
+
+ return 1
+}
+
+do_filter_flags() {
+ declare setting
+
+ # In general gcc does not like optimization, and add -O2 where
+ # it is safe. This is especially true for gcc 3.3 + 3.4
+ replace-flags -O? -O2
+
+ # gcc 3.3 doesn't support -mtune on numerous archs, so xgcc will fail
+ setting="`get-flag mtune`"
+ [[ ! -z "${setting}" ]] && filter-flags -mtune="${setting}"
+
+ # in gcc 3.3 there is a bug on ppc64 where if -mcpu is used
+ # the compiler incorrectly assumes the code you are about to build
+ # is 32 bit
+ use ppc64 && setting="`get-flag mcpu`"
+ [[ ! -z "${setting}" ]] && filter-flags -mcpu="${setting}"
+
+ # only allow the flags that we -know- are supported
+ transform_known_flags
+ setting="`get-flag march`"
+ if [[ ! -z "${setting}" ]] ; then
+ is_arch_allowed "${setting}" || filter-flags -march="${setting}"
+ fi
+ setting="`get-flag mcpu`"
+ if [[ ! -z "${setting}" ]] ; then
+ is_arch_allowed "${setting}" || filter-flags -mcpu="${setting}"
+ fi
+
+ # xgcc wont understand gcc 3.4 flags...
+ filter-flags -fno-unit-at-a-time
+ filter-flags -funit-at-a-time
+ filter-flags -fweb
+ filter-flags -fno-web
+ filter-flags -mno-tls-direct-seg-refs
+
+ # xgcc isnt patched with propolice
+ filter-flags -fstack-protector-all
+ filter-flags -fno-stack-protector-all
+ filter-flags -fstack-protector
+ filter-flags -fno-stack-protector
+
+ # xgcc isnt patched with the gcc symbol visibility patch
+ filter-flags -fvisibility-inlines-hidden
+ filter-flags -fvisibility=hidden
+
+ # Bug #269433 & #290202
+ filter-flags -fno-strict-overflow
+ filter-flags -fstrict-overflow
+
+ # Bug #442784
+ filter-flags '-W*'
+
+ filter-flags -frecord-gcc-switches
+ filter-flags '-fdiagnostics-color*'
+
+ # Bug #610064
+ filter-flags '-fstack-check*'
+
+ # ...sure, why not?
+ strip-unsupported-flags
+
+ strip-flags
+}
+
+S=${WORKDIR}/gcc-${PV}
+
+src_prepare() {
+ eapply "${WORKDIR}"/patch/*.patch
+
+ default
+
+ elibtoolize --portage --shallow
+ ./contrib/gcc_update --touch
+
+ if use multilib && [[ ${SYMLINK_LIB} == "yes" ]] ; then
+ # ugh, this shit has to match the way we've hacked gcc else
+ # the build falls apart #259215
+ sed -i \
+ -e 's:\(MULTILIB_OSDIRNAMES = \).*:\1../lib64 ../lib32:' \
+ "${S}"/gcc/config/i386/t-linux64 \
+ || die "sed failed!"
+ fi
+
+ tc-export AR CC RANLIB NM
+}
+
+src_configure() {
+ mkdir -p "${WORKDIR}"/build
+ cd "${WORKDIR}"/build
+ do_filter_flags
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-shared \
+ --with-system-zlib \
+ --enable-languages=c++ \
+ --enable-threads=posix \
+ --enable-long-long \
+ --disable-checking \
+ --enable-cstdio=stdio \
+ --enable-__cxa_atexit \
+ $(use_enable multilib) \
+ $(use_enable nls) \
+ $(use_with !nls included-gettext)
+
+ touch "${S}"/gcc/c-gperf.h
+}
+
+src_compile() {
+ emake \
+ -C "${WORKDIR}"/build all-target-libstdc++-v3 \
+ AR="$(tc-getAR)" \
+ NM="$(tc-getNM)"
+}
+
+src_install() {
+ emake -j1 \
+ -C "${WORKDIR}"/build \
+ AR="$(tc-getAR)" \
+ NM="$(tc-getNM)" \
+ DESTDIR="${D}" \
+ install-target-libstdc++-v3
+
+ # scrub everything but the library we care about
+ pushd "${D}" >/dev/null
+ mv usr/lib* . || die
+ rm -rf usr
+ rm -f lib*/*.{a,la,so} || die
+ dodir /usr
+ mv lib* usr/ || die
+}