summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-01 02:51:40 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-01 02:55:50 +0100
commit57d643449f605608ba7eb3ea82fd46f2512263bd (patch)
treeb3012eac79127719579205de94f9df08a53d11e0
parentsci-libs/bmrblib: Remove old (py3.6) (diff)
downloadgentoo-57d64344.tar.gz
gentoo-57d64344.tar.bz2
gentoo-57d64344.zip
sci-libs/dlib: Remove old (py3.6)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sci-libs/dlib/Manifest1
-rw-r--r--sci-libs/dlib/dlib-19.9.ebuild77
2 files changed, 0 insertions, 78 deletions
diff --git a/sci-libs/dlib/Manifest b/sci-libs/dlib/Manifest
index 6682430cf3ae..63c671d911e7 100644
--- a/sci-libs/dlib/Manifest
+++ b/sci-libs/dlib/Manifest
@@ -1,2 +1 @@
DIST dlib-19.16.tar.gz 10411975 BLAKE2B 93047590a4d8f4685970d3db6841cbf9cc90ca8a5e50f0929a106d887e5db1b4fd96bbe14380537a3e28369a8db6d9d8c067e7768000ac3c7d0f225b46369326 SHA512 4e040ef88acff05e1a48e499b813c876b22ad3f989d076bdf19969d01036b62e51a0dff30b70046910ba31dfa1b1c2450a7fad41ae3142b7285ed74b8d584887
-DIST dlib-19.9.tar.gz 8892457 BLAKE2B d18548e09f8169bbc9d7f339599bd58b940410839b259a8d7be9cb999f82e634ad5cd0539adb45239dab821ea1029493d24ae9990ca32c75c744e2c5d9e218f6 SHA512 1e2123c22e1b13cc84108fa627bfa92eadc9dee63f93a9f45676bbf2b752c8728117d915ac327f5223b0cdbce87dd3bef2f4d8d5ed3f8f5a314ffa9e8962a246
diff --git a/sci-libs/dlib/dlib-19.9.ebuild b/sci-libs/dlib/dlib-19.9.ebuild
deleted file mode 100644
index fcc55d70b0e1..000000000000
--- a/sci-libs/dlib/dlib-19.9.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-inherit python-r1 cmake-utils cuda
-
-DESCRIPTION="Numerical and networking C++ library"
-HOMEPAGE="http://dlib.net/"
-SRC_URI="https://github.com/davisking/dlib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Boost-1.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cblas debug cuda examples gif jpeg lapack mkl png python sqlite static-libs test X"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-# doc needs a bunch of deps not in portage
-
-RDEPEND="
- cblas? ( virtual/cblas:= )
- cuda? ( dev-libs/cudnn:= )
- jpeg? ( virtual/jpeg:0= )
- lapack? ( virtual/lapack:= )
- mkl? ( sci-libs/mkl:= )
- png? ( media-libs/libpng:0= )
- python? ( ${PYTHON_DEPS} )
- sqlite? ( dev-db/sqlite:3= )
- X? ( x11-libs/libX11:= )
-"
-DEPEND="test? ( ${RDEPEND} )"
-
-src_prepare() {
- use cuda && cuda_src_prepare
- cmake-utils_src_prepare
- sed -i -e '/LICENSE.txt/d' dlib/CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="$(get_libdir)"
- -DDLIB_ENABLE_ASSERTS="$(usex debug)"
- -DDLIB_ENABLE_STACK_TRACE="$(usex debug)"
- -DDLIB_GIF_SUPPORT="$(usex gif)"
- -DDLIB_JPEG_SUPPORT="$(usex jpeg)"
- -DDLIB_PNG_SUPPORT="$(usex png)"
- -DDLIB_LINK_WITH_SQLITE3="$(usex sqlite)"
- -DDLIB_NO_GUI_SUPPORT="$(usex X OFF ON)"
- -DDLIB_USE_BLAS="$(usex cblas)"
- -DDLIB_USE_CUDA="$(usex cuda)"
- -DDLIB_USE_LAPACK="$(usex lapack)"
- -DBOOST_LIBRARYDIR="${EPREFIX}/usr/$(get_libdir)"
- )
- cmake-utils_src_configure
-}
-
-src_test() {
- mkdir "${BUILD_DIR}"/dlib/test || die
- pushd "${BUILD_DIR}"/dlib/test > /dev/null || die
- cmake "${S}"/dlib/test && emake
- ./dtest --runall || die
- popd > /dev/null || die
-}
-
-src_install() {
- cmake-utils_src_install
- if use python; then
- python_foreach_impl python_domodule ${PN}
- fi
- dodoc docs/README.txt
- use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}
- fi
-}