summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-11 06:43:51 +0100
committerSam James <sam@gentoo.org>2022-06-11 06:48:03 +0100
commit57dc9f52aa59e0f9430aa7a46579190f316ee9e2 (patch)
treea9fe8cbe9eab8a3cc9cc0653af2fe1ce40b3d095
parentsys-apps/ethq: cosmetic changes to live ebuild (diff)
downloadgentoo-57dc9f52.tar.gz
gentoo-57dc9f52.tar.bz2
gentoo-57dc9f52.zip
sys-apps/ethq: don't revbump for Werror fix
Bug: https://bugs.gentoo.org/770943 See: https://github.com/gentoo/gentoo/pull/19561 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/ethq/ethq-0.6.1-r1.ebuild56
-rw-r--r--sys-apps/ethq/ethq-0.6.1.ebuild10
-rw-r--r--sys-apps/ethq/ethq-9999.ebuild4
3 files changed, 7 insertions, 63 deletions
diff --git a/sys-apps/ethq/ethq-0.6.1-r1.ebuild b/sys-apps/ethq/ethq-0.6.1-r1.ebuild
deleted file mode 100644
index b95aba17d42b..000000000000
--- a/sys-apps/ethq/ethq-0.6.1-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PV=${PV//./_}
-MY_P=${PN}-${MY_PV}
-
-inherit toolchain-funcs
-
-DESCRIPTION="Ethernet NIC Queue stats viewer"
-HOMEPAGE="https://github.com/isc-projects/ethq"
-SRC_URI="https://github.com/isc-projects/ethq/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="sys-libs/ncurses:0"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
-
- # Respect FLAGS, remove Werror
- sed -i -e '/CXXFLAGS/s/= -O3/+=/' \
- -e '/CXXFLAGS/s/ -Werror//' \
- -e '/LDFLAGS/s/=/+=/' Makefile || die "sed failed for Makefile"
-
- if ! use test ; then
- sed -i '/TARGETS/s/ethq_test//' Makefile \
- || die "sed failed for USE flag test"
- fi
-}
-
-src_compile() {
- # override for ncurses[tinfo]
- emake CXX="$(tc-getCXX)" LIBS_CURSES="$($(tc-getPKG_CONFIG) --libs ncurses)"
-}
-
-src_test() {
- local driver
- for driver in tests/* ; do
- "${S}"/ethq_test "${driver##*/}" "${driver}" \
- || die "test failed on ${driver}"
- done
-}
-
-src_install() {
- einstalldocs
- dobin ethq
-}
diff --git a/sys-apps/ethq/ethq-0.6.1.ebuild b/sys-apps/ethq/ethq-0.6.1.ebuild
index 6749cb3094e6..172f1ef054f7 100644
--- a/sys-apps/ethq/ethq-0.6.1.ebuild
+++ b/sys-apps/ethq/ethq-0.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,17 +18,17 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="sys-libs/ncurses:0="
+DEPEND="sys-libs/ncurses:="
RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
src_prepare() {
default
- # Respect FLAGS
- sed -i -e '/CXXFLAGS/s/= -O3/+=/' \
+ # Respect FLAGS, remove Werror
+ sed -i -e '/CXXFLAGS/s/= -O3/+=/' \
+ -e '/CXXFLAGS/s/ -Werror//' \
-e '/LDFLAGS/s/=/+=/' Makefile || die "sed failed for Makefile"
if ! use test ; then
diff --git a/sys-apps/ethq/ethq-9999.ebuild b/sys-apps/ethq/ethq-9999.ebuild
index ce1c594d966b..11b6f2389400 100644
--- a/sys-apps/ethq/ethq-9999.ebuild
+++ b/sys-apps/ethq/ethq-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ KEYWORDS=""
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="sys-libs/ncurses:0="
+DEPEND="sys-libs/ncurses:="
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"