summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-10-03 10:52:33 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-10-03 10:52:33 +0100
commit57f3ff89af279f3b269ecc35e8063abce4800121 (patch)
tree37e507f16ccf2e6d64dacd93c508641964c76652
parentdev-haskell/biosff: update to EAPI=7 (diff)
downloadgentoo-57f3ff89.tar.gz
gentoo-57f3ff89.tar.bz2
gentoo-57f3ff89.zip
dev-haskell/bits-atomic: update to EAPI=7
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild b/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild
index 11024cb68c50..278b011fad91 100644
--- a/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild
+++ b/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
# ebuild generated by hackport 0.4.6.9999
@@ -29,7 +29,7 @@ DEPEND="${RDEPEND}
dev-haskell/test-framework-quickcheck2 )
"
-src_prepare() {
- epatch "${DISTDIR}"/${P}-gcc-5.patch
- epatch "${FILESDIR}"/${P}-ghc-8.patch
-}
+PATCHES=(
+ "${DISTDIR}"/${P}-gcc-5.patch
+ "${FILESDIR}"/${P}-ghc-8.patch
+)