summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-29 21:25:48 +0000
committerSam James <sam@gentoo.org>2022-12-29 21:26:44 +0000
commit582813bc85632cd46b874ca1f9fba48e22fc73a0 (patch)
treef5449eac0c4008120f96a54ea1ffb98eaa9014db
parentapp-doc/doxygen: add 1.9.6 (diff)
downloadgentoo-582813bc.tar.gz
gentoo-582813bc.tar.bz2
gentoo-582813bc.zip
www-client/elinks: add 0.16.0
Note that this adds USE=javascript masked because it can't work yet (because of pending libxmlpp bump) but added to ensure we don't forget about it. Bug: https://bugs.gentoo.org/797427 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--profiles/base/package.use.mask4
-rw-r--r--www-client/elinks/Manifest1
-rw-r--r--www-client/elinks/elinks-0.16.0.ebuild163
-rw-r--r--www-client/elinks/elinks-9999.ebuild15
4 files changed, 180 insertions, 3 deletions
diff --git a/profiles/base/package.use.mask b/profiles/base/package.use.mask
index 0e241ff8be84..26983de4b5a7 100644
--- a/profiles/base/package.use.mask
+++ b/profiles/base/package.use.mask
@@ -6,6 +6,10 @@
# This file is only for generic masks. For arch-specific masks (i.e.
# mask everywhere, unmask on arch/*) use arch/base.
+# Sam James <sam@gentoo.org> (2022-12-29)
+# Needs yet-unpackaged libxmlpp-5.0, bug #888898
+www-client/elinks javascript
+
# Ionen Wolkens <ionen@gentoo.org> (2022-12-29)
# Blocks eventual cleanup of <dev-util/glslang-1.3.231, and the same
# functionality can be got through USE=shaderc without direct usage.
diff --git a/www-client/elinks/Manifest b/www-client/elinks/Manifest
index ccbe603223be..e78cffa828a7 100644
--- a/www-client/elinks/Manifest
+++ b/www-client/elinks/Manifest
@@ -1,2 +1,3 @@
DIST elinks-0.13.5.tar.gz 3600196 BLAKE2B e1e51674b5630d6dab3de3030aee671876750fc97808bf4dca50b505fa2c31af669c4c3773b3830186fb98acda5c692ff1902c6e1240251ea699103a70bb4e43 SHA512 786f6142c03bca4a47a1043ca4f9c36aab431d192eb13bcad14c1da391f5746779a8f65e53eb781dff79f619ceb3ed30ef939eae8d81f64251fad9b803c0ae7b
DIST elinks-0.15.1.tar.xz 1997208 BLAKE2B dcec7054d417842e709f26bab53ddb1bf43556de4c69d116ad1e049664bc7c5a5513f02cee500d591252b439a66f354079e2e3eff5692202102cb900e06340c2 SHA512 677eeeeab3fc24dcfe4e7248a9c1a8e07083ebd13bd9923d89702a04dbe1c3e4d4038029c095881183d7f11ae2c5317ff7e5458320644fde0c176378b89068d8
+DIST elinks-0.16.0.tar.xz 2029708 BLAKE2B b81dfeb303d2e33c88f063925f61dbf50a1cf8462cf3d000b70e01b210855682352303646c7d4dc2c5bdd0de41c3ce33d222c636be4d8292cbe8379b4b043ef8 SHA512 b1d6040b691610d596e0d1eae26bfe52d702272c71a2e5100ab7d6b05b24a0b88524d4fc7be3f6371e0bada1e6f0992da7505a72419ca642dec778424629a522
diff --git a/www-client/elinks/elinks-0.16.0.ebuild b/www-client/elinks/elinks-0.16.0.ebuild
new file mode 100644
index 000000000000..3c1f97b7f5ff
--- /dev/null
+++ b/www-client/elinks/elinks-0.16.0.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+LUA_COMPAT=( lua5-{1,2,3,4} luajit )
+
+inherit meson lua-single python-any-r1
+
+DESCRIPTION="Advanced and well-established text-mode web browser"
+HOMEPAGE="http://elinks.or.cz/"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/rkd77/felinks"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/rkd77/elinks/releases/download/v${PV}/${P}.tar.xz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm gnutls guile idn"
+IUSE+=" javascript lua lzma +mouse nls nntp perl samba ssl test tre unicode X xml zlib zstd"
+# tests restricted for https://github.com/rkd77/elinks/issues/203
+RESTRICT="!test? ( test ) test"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2:=[unicode(+)]
+ brotli? ( app-arch/brotli:= )
+ bzip2? ( >=app-arch/bzip2-1.0.2 )
+ gpm? (
+ >=sys-libs/gpm-1.20.0-r5
+ )
+ guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated] )
+ idn? ( net-dns/libidn:= )
+ javascript? (
+ dev-cpp/libxmlpp:5.0
+ dev-lang/mujs:=
+ )
+ lua? ( ${LUA_DEPS} )
+ lzma? ( app-arch/xz-utils )
+ perl? ( dev-lang/perl:= )
+ samba? ( net-fs/samba )
+ ssl? (
+ !gnutls? ( dev-libs/openssl:= )
+ gnutls? ( net-libs/gnutls:= )
+ )
+ tre? ( dev-libs/tre )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ )
+ xml? ( >=dev-libs/expat-1.95.4 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+
+ python-any-r1_pkg_setup
+}
+
+
+src_configure() {
+ local emesonargs=(
+ -D88-colors=true
+ -D256-colors=true
+ $(meson_use bittorrent)
+ $(meson_use brotli)
+ $(meson_use bzip2 bzlib)
+ $(usex debug '-Ddebug=true' '-Dfastmem=true')
+ $(meson_use finger)
+ $(meson_use ftp)
+ -Dfsp=false
+ -Dgemini=false
+ -Dgettext=true
+ $(meson_use gopher)
+ $(meson_use gpm)
+ $(meson_use guile)
+ -Dgssapi=false
+ -Dhtml-highlight=true
+ $(meson_use idn)
+ $(meson_use javascript mujs)
+ -Dipv6=true
+ -Dleds=true
+ -Dlibev=false
+ -Dlibevent=false
+ -Dluapkg=$(usex lua ${ELUA:-0} '')
+ $(meson_use lzma)
+ $(meson_use mouse)
+ #-Dmujs=false
+ $(meson_use nls)
+ $(meson_use nntp)
+ $(meson_use perl)
+ -Dpython=false
+ -Dquickjs=false
+ -Druby=false
+ $(meson_use samba smb)
+ -Dsm-scripting=false
+ -Dspidermonkey=false
+ -Dterminfo=true
+ $(meson_use test)
+ $(meson_use tre)
+ -Dtrue-color=true
+ $(meson_use xml xbel)
+ $(meson_use X x)
+ $(meson_use zlib)
+ $(meson_use zstd)
+ )
+
+ if use ssl ; then
+ if use gnutls ; then
+ emesonargs+=( -Dgnutls=true )
+ else
+ emesonargs+=( -Dopenssl=true)
+ fi
+ else
+ emesonargs+=( -Dgnutls=false -Dopenssl=false )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /etc/elinks
+ newins contrib/keybind-full.conf keybind-full.sample
+ newins contrib/keybind.conf keybind.conf.sample
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES THANKS TODO doc/*.*
+ docinto contrib ; dodoc contrib/{README,colws.diff,elinks[-.]vim*}
+ docinto contrib/lua ; dodoc contrib/lua/{*.lua,elinks-remote}
+ docinto contrib/conv ; dodoc contrib/conv/*.*
+ docinto contrib/guile ; dodoc contrib/guile/*.scm
+
+ # elinks uses an internal copy of gettext which ships files that may
+ # collide with the system's gettext (https://bugs.gentoo.org/635090)
+ rm -f "${ED}"/usr/{share/locale/locale,lib/charset}.alias || die
+}
+
+pkg_postinst() {
+ elog "You may want to convert your html.cfg and links.cfg of"
+ elog "Links or older ELinks versions to the new ELinks elinks.conf"
+ elog "using ${EROOT}/usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
+ elog
+ elog "Please have a look at ${EROOT}/etc/elinks/keybind-full.sample and"
+ elog "${EROOT}/etc/elinks/keybind.conf.sample for some bindings examples."
+ elog
+ elog "You will have to set your TERM variable to 'xterm-256color'"
+ elog "to be able to use 256 colors in elinks."
+}
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
index 20caa1f92b40..3c1f97b7f5ff 100644
--- a/www-client/elinks/elinks-9999.ebuild
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-LUA_COMPAT=( lua5-{1,2} )
+LUA_COMPAT=( lua5-{1,2,3,4} luajit )
inherit meson lua-single python-any-r1
@@ -22,8 +22,10 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm gnutls guile idn
- lua lzma +mouse nls nntp perl samba ssl tre unicode X xml zlib zstd"
+IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm gnutls guile idn"
+IUSE+=" javascript lua lzma +mouse nls nntp perl samba ssl test tre unicode X xml zlib zstd"
+# tests restricted for https://github.com/rkd77/elinks/issues/203
+RESTRICT="!test? ( test ) test"
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
RDEPEND="
@@ -35,6 +37,10 @@ RDEPEND="
)
guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated] )
idn? ( net-dns/libidn:= )
+ javascript? (
+ dev-cpp/libxmlpp:5.0
+ dev-lang/mujs:=
+ )
lua? ( ${LUA_DEPS} )
lzma? ( app-arch/xz-utils )
perl? ( dev-lang/perl:= )
@@ -65,6 +71,7 @@ pkg_setup() {
python-any-r1_pkg_setup
}
+
src_configure() {
local emesonargs=(
-D88-colors=true
@@ -84,6 +91,7 @@ src_configure() {
-Dgssapi=false
-Dhtml-highlight=true
$(meson_use idn)
+ $(meson_use javascript mujs)
-Dipv6=true
-Dleds=true
-Dlibev=false
@@ -102,6 +110,7 @@ src_configure() {
-Dsm-scripting=false
-Dspidermonkey=false
-Dterminfo=true
+ $(meson_use test)
$(meson_use tre)
-Dtrue-color=true
$(meson_use xml xbel)