summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-01 06:44:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-01 06:55:23 +0200
commit58341679929a3fcce8696b852b1cf2b391f83cea (patch)
treec87cb684eac45d55682ac4562f9d0bb07d49f9e3
parentdev-python/google-api-core: Bump to 2.0.1 (diff)
downloadgentoo-58341679.tar.gz
gentoo-58341679.tar.bz2
gentoo-58341679.zip
dev-python/google-auth: Bump to 2.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.0.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index cceeac4bb5de..d522985c4378 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,2 +1,3 @@
DIST google-auth-1.34.0.tar.gz 180860 BLAKE2B d536d689ff5b0c033f787228d643504d1888f0b73a9c6855fe4fae3af20772ef0640feca39c58c39f45681561dce6d5f3ec1d1f7d9699442fff0ec63fd019361 SHA512 7c3b64e8f85056fb660bbfd4f737053813a1e5b8aba52290882a0ddb9d9fd8c5365b767c78dd1e7859ef95caa6e653786d5a8747c8792bbee9c6fad1a5218910
DIST google-auth-2.0.1.tar.gz 180467 BLAKE2B a7490931ea8cdec0978103d9bb4da11bebff1e623d847db5fb30a0a7ef1827902b4d5683835631b645e61d4282614e3efc798bedc13a581ba35d51838a64ff96 SHA512 a68f78a7d67beb4d3d00333f6953decd92e1d346aee6491c401ee091d2fb4bbac47b9ecc46f7063119724a49f15ea13c096994e5266d30975500194b9c4a9df0
+DIST google-auth-2.0.2.tar.gz 180445 BLAKE2B d4e9e7dcfd690f5eedf301e989c4a2dedf509e7c3068e4f547ea43f870979a6001d21849a7102321f6f843196f0a4e0a14f888bd3b43701c301aea3a7f94ed60 SHA512 b8cec2fec4105715edad3242f20ac26b7ab2591903785ed5c31c1af19f7a23e14e93e0d4c3644dca76db5ec0353b8a1baba0224d67987067c5580c75592a04e8
diff --git a/dev-python/google-auth/google-auth-2.0.2.ebuild b/dev-python/google-auth/google-auth-2.0.2.ebuild
new file mode 100644
index 000000000000..cd44f928efdd
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.0.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}