summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-17 07:47:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-17 08:16:51 +0200
commit587e6e0e70cf6aa39dbeecf9418311a3079c9877 (patch)
tree71ea2e2f2c7fb71a842c84e452ed4a7651235e4c
parentdev-python/setuptools: Bump to 65.0.2 (diff)
downloadgentoo-587e6e0e.tar.gz
gentoo-587e6e0e.tar.bz2
gentoo-587e6e0e.zip
dev-python/ensurepip-setuptools: Bump to 65.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ensurepip-setuptools/Manifest1
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-65.0.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/Manifest b/dev-python/ensurepip-setuptools/Manifest
index 74e325e1c68b..2aec9cabe3a8 100644
--- a/dev-python/ensurepip-setuptools/Manifest
+++ b/dev-python/ensurepip-setuptools/Manifest
@@ -1 +1,2 @@
DIST setuptools-65.0.0-py3-none-any.whl 1217438 BLAKE2B 07e9bbc6c316edbd9f1110cfbd6203f3848ff406c88e0b7bf5fdd7454ca6ace467da6b34d47c126ecf19551504f9a40b4b47ac07509eeef2642b4408489fbe25 SHA512 ca73a8aee402175084461a8a20381ec1ab8885cb360eca3cad02b2d89da363786ff9a9c3406d8539bf1e20eac38ee1afad927ec4b7f2572decfff947f79bcacf
+DIST setuptools-65.0.2-py3-none-any.whl 1233332 BLAKE2B 0c0d0db73452d15947097f3d453f01bb42ef150b50122b7a1f39212f663064284bc313a04c3dbe99e8da7e614d72a963d6c9f0c8f486f5d84131a06718b288c8 SHA512 11d9975468166bf7db9a9da44d893a67daacc5f309da1b521278a95a33fa2b3574cae10840c9943de54bf5d411e54697f91b62a3bfb5a6a3bc69b804af2a1365
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.0.2.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.0.2.ebuild
new file mode 100644
index 000000000000..96c75c915768
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN#ensurepip-}
+WHL=${MY_PN}-${PV}-py3-none-any.whl
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${MY_PN::1}/${MY_PN}/${WHL}
+"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${WHL}"
+}