summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-10-02 21:22:31 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-10-02 21:24:53 +0200
commit588af89aae206ad01a2b80248e993d92b25084fe (patch)
treedb8ff5fabe3b2d218d47826c1fc07b00e3e1f997
parentdev-libs/libbpf: bump to 0.1.1 (diff)
downloadgentoo-588af89a.tar.gz
gentoo-588af89a.tar.bz2
gentoo-588af89a.zip
www-client/firefox: USE=debug implies --enable-debug-symbols
Bug: https://bugs.gentoo.org/746131 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-client/firefox/firefox-78.3.1.ebuild8
-rw-r--r--www-client/firefox/firefox-81.0.1.ebuild8
2 files changed, 2 insertions, 14 deletions
diff --git a/www-client/firefox/firefox-78.3.1.ebuild b/www-client/firefox/firefox-78.3.1.ebuild
index b5f29994dffb..3e0f59ad97ae 100644
--- a/www-client/firefox/firefox-78.3.1.ebuild
+++ b/www-client/firefox/firefox-78.3.1.ebuild
@@ -557,16 +557,10 @@ src_configure() {
mozconfig_use_enable debug
if use debug ; then
- if is-flag '-g*' ; then
- mozconfig_add_options_ac '+debug' --enable-debug-symbols=$(get-flag '-g*')
- else
- mozconfig_add_options_ac '+debug' --enable-debug-symbols
- fi
-
mozconfig_add_options_ac '+debug' --disable-optimize
else
if is-flag '-g*' ; then
- mozconfig_add_options_ac '+debug' --enable-debug-symbols=$(get-flag '-g*')
+ mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols=$(get-flag '-g*')
else
mozconfig_add_options_ac 'Gentoo default' --disable-debug-symbols
fi
diff --git a/www-client/firefox/firefox-81.0.1.ebuild b/www-client/firefox/firefox-81.0.1.ebuild
index 986291f0ae36..eb407d1a1c97 100644
--- a/www-client/firefox/firefox-81.0.1.ebuild
+++ b/www-client/firefox/firefox-81.0.1.ebuild
@@ -557,16 +557,10 @@ src_configure() {
mozconfig_use_enable debug
if use debug ; then
- if is-flag '-g*' ; then
- mozconfig_add_options_ac '+debug' --enable-debug-symbols=$(get-flag '-g*')
- else
- mozconfig_add_options_ac '+debug' --enable-debug-symbols
- fi
-
mozconfig_add_options_ac '+debug' --disable-optimize
else
if is-flag '-g*' ; then
- mozconfig_add_options_ac '+debug' --enable-debug-symbols=$(get-flag '-g*')
+ mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols=$(get-flag '-g*')
else
mozconfig_add_options_ac 'Gentoo default' --disable-debug-symbols
fi