summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-07 15:39:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-07 15:52:50 +0200
commit589c5285f4cdf8207ba9189793d21df0d5a09bb1 (patch)
treea16dde3c8095e259c110e7e50355d3bf502c704a
parentpython-utils-r1.eclass: Cleanup cache dirs after epytest (diff)
downloadgentoo-589c5285f4cdf8207ba9189793d21df0d5a09bb1.tar.gz
gentoo-589c5285f4cdf8207ba9189793d21df0d5a09bb1.tar.bz2
gentoo-589c5285f4cdf8207ba9189793d21df0d5a09bb1.zip
dev-python/pyftpdlib: Enable 'travis mode' to make tests fail less
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
index 919f9cb3f630..21ad58b09d22 100644
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
@@ -40,16 +40,9 @@ python_test() {
local skipped_tests=(
# Those tests are run separately
pyftpdlib/test/test_misc.py
- # https://github.com/giampaolo/pyftpdlib/issues/470
- # https://bugs.gentoo.org/659108
- pyftpdlib/test/test_functional_ssl.py::TestTimeouts::test_idle_data_timeout2
- pyftpdlib/test/test_functional_ssl.py::TestTimeoutsTLSMixin::test_idle_data_timeout2
# https://github.com/giampaolo/pyftpdlib/issues/471
# https://bugs.gentoo.org/636410
pyftpdlib/test/test_functional.py::TestCallbacks::test_on_incomplete_file_received
- # https://github.com/giampaolo/pyftpdlib/issues/466
- # https://bugs.gentoo.org/659786
- pyftpdlib/test/test_functional_ssl.py::TestFtpListingCmdsTLSMixin::test_nlst
# https://github.com/giampaolo/pyftpdlib/issues/512
# https://bugs.gentoo.org/701146
pyftpdlib/test/test_functional_ssl.py::TestFtpStoreDataTLSMixin::test_rest_on_stor
@@ -74,7 +67,10 @@ python_test() {
pyftpdlib/test/test_functional_ssl.py::TestConfigurableOptionsTLSMixin::test_masquerade_address_map
)
# Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
- TZ=UTC+1 epytest -p no:xvfb ${skipped_tests[@]/#/--deselect }
+ local -x TZ=UTC+1
+ # Skips some shoddy tests plus increases timeouts
+ local -x TRAVIS=1
+ epytest -p no:xvfb ${skipped_tests[@]/#/--deselect }
}
python_install_all() {