summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-25 08:39:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-25 09:56:21 +0200
commit58a30ba5c6ca07f3612dfdad5136ad4587c1aa3f (patch)
tree99b075fbdd15e77e8d76e606ecd3b77256842f5a
parentdev-python/sphinx-gallery: Bump to 0.9.0 (diff)
downloadgentoo-58a30ba5.tar.gz
gentoo-58a30ba5.tar.bz2
gentoo-58a30ba5.zip
dev-python/pytest-mock: Bump to 3.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-mock/Manifest1
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.6.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 096fe5f7f6f7..945d631ce790 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1 +1,2 @@
DIST pytest-mock-3.5.1.tar.gz 29135 BLAKE2B f9eb37bff0965772919c359ad56a0cdd0cac24fa763685c42ffaa2dfaea183a9c0be480269cbfc80990baaf406021c541b6dccc09602e98c8f731bbd530e928a SHA512 28ab2f239d3dfee134dd4e4fd467109cf3c76cb60aeb537dbc0c21b9a7619d068d54737e33d98c585e9341588fdafba4737ea5f428af37796f55e61ec30373a7
+DIST pytest-mock-3.6.0.tar.gz 29795 BLAKE2B ac0a9ebf47ceacaa6f1e109571a15509780ca25b67f46a74710fb81e3af4cb90f4bf95e077abd9c5be803fed1a4dfe691f57f4b0d89fbc91cb91ed85fd326f9b SHA512 158614ad655545a95134335b6ca5ab81bfae57a045a6e394c4195d267e2b5cce277302036ad7e23e3c771eaae71575b901ac3e02a734714d63ecb50c11b9df94
diff --git a/dev-python/pytest-mock/pytest-mock-3.6.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.6.0.ebuild
new file mode 100644
index 000000000000..c63a62d05f00
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-3.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/pytest-5[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=()
+ if has_version dev-python/mock; then
+ deselect+=(
+ tests/test_pytest_mock.py::test_standalone_mock
+ )
+ fi
+
+ distutils_install_for_testing
+ epytest --assert=plain ${deselect[@]/#/--deselect }
+}