summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph McElroy <59029169+jmcelroy01@users.noreply.github.com>2023-10-08 13:04:00 +0200
committerDavid Seifert <soap@gentoo.org>2023-10-08 13:04:00 +0200
commit58f2ca73cb9d631c1b90a6590e320711419127be (patch)
tree46d916e46bd98e8ee254f7e61c0b93fa08c9afed
parentdev-libs/tree-sitter-typescript: add 0.20.3 (diff)
downloadgentoo-58f2ca73cb9d631c1b90a6590e320711419127be.tar.gz
gentoo-58f2ca73cb9d631c1b90a6590e320711419127be.tar.bz2
gentoo-58f2ca73cb9d631c1b90a6590e320711419127be.zip
app-admin/fsvs: add 1.2.11
Bug: https://bugs.gentoo.org/439204 Bug: https://bugs.gentoo.org/693650 Bug: https://bugs.gentoo.org/729112 Bug: https://bugs.gentoo.org/830267 Bug: https://bugs.gentoo.org/865267 Bug: https://bugs.gentoo.org/875677 Closes: https://bugs.gentoo.org/912970 Signed-off-by: Joseph McElroy <59029169+jmcelroy01@users.noreply.github.com> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-admin/fsvs/Manifest1
-rw-r--r--app-admin/fsvs/files/fsvs-1.2.11-makefile.patch68
-rw-r--r--app-admin/fsvs/fsvs-1.2.11.ebuild55
3 files changed, 124 insertions, 0 deletions
diff --git a/app-admin/fsvs/Manifest b/app-admin/fsvs/Manifest
index 6230e2cc48f2..0b41d5b12256 100644
--- a/app-admin/fsvs/Manifest
+++ b/app-admin/fsvs/Manifest
@@ -1 +1,2 @@
+DIST fsvs-1.2.11.tar.gz 498514 BLAKE2B 8683fe3c22a0ea0d4762d631e520596dc02d69059f4ff5d8719bd44405134e5b5100c594a260d1b55a9dd7c6d240a84a0c5e05a18006a7a5f193ce76178d934c SHA512 72f883dfef85cb8aeb4d3baf3a2de5bfb6b5479273027f86b52edfdd2ea6dac4b2271b83a9879add3d7c9008f80a2fef13671b9e5ed61958c72ff144d9fad086
DIST fsvs-1.2.5.tar.bz2 427494 BLAKE2B ac445bd6572ccdc589ec3d9e21127446a0553d29ac62b1e99e60b767cb1c06d8be13469bcdef03382fa6088bb3fdb740a10a0e39fc5707fbfba749472523bc12 SHA512 36ab5d04491d506b2891548f3ad458e7977bbd2e7d4b03e135b13d07adb22aedb261c28d5ddd3df895771806ef54c1bca6a1ef7bc5aa2e50e4b234ddf6cbe19c
diff --git a/app-admin/fsvs/files/fsvs-1.2.11-makefile.patch b/app-admin/fsvs/files/fsvs-1.2.11-makefile.patch
new file mode 100644
index 000000000000..93daf9521d3e
--- /dev/null
+++ b/app-admin/fsvs/files/fsvs-1.2.11-makefile.patch
@@ -0,0 +1,68 @@
+--- a/Makefile
++++ b/Makefile
+@@ -13,7 +13,7 @@
+ @echo ''
+ @false
+
+-configure: configure.in
++configure: configure.ac
+ @echo Generating configure.
+ autoconf
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -11,10 +11,11 @@
+ ################################ Definitions ################################
+ DIR := /usr/share/doc
+
+-VERSION := $(shell git describe --tags --always)
++VERSION := 1.2.11
+
++CC := @CC@
+ CFLAGS := @CFLAGS@
+-CFLAGS += -Wall -funsigned-char -Os -DFSVS_VERSION='"$(VERSION)"' -Wno-deprecated-declarations
++CFLAGS += -Wall -funsigned-char -DFSVS_VERSION='"$(VERSION)"' -Wno-deprecated-declarations
+ LDFLAGS := @LDFLAGS@
+ FSVS_LDFLAGS = $(LDFLAGS)
+ BASELIBS := -lsvn_subr-1 -lsvn_delta-1 -lsvn_ra-1 -lpcre2-8 -lgdbm -ldl
+@@ -48,11 +49,7 @@
+
+
+ ################################ Targets ###################################
+-ifeq (@CHROOTER_JAIL@, )
+-all: deps tags check-version check-dox $(DEST) lsDEST
+-else
+-all: tools/fsvs-chrooter
+-endif
++all: fsvs
+
+
+ check-version: config.h fsvs.c
+@@ -145,18 +142,11 @@
+
+
+ ################################ Rules ######################################
+-%.o: %.c
+- @echo " CC $<"
+- @$(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
+
+ # if the Makefile has changed, the output will (at least sometimes)
+ # change, too.
+ $(DEST): $(C_FILES:%.c=%.o)
+- @echo " Link $@"
+- @$(CC) $(FSVS_LDFLAGS) $(LDLIBS) $(LIBS) -o $@ $^ $(BASELIBS) $(EXTRALIBS)
+-ifeq (@ENABLE_RELEASE@, 1)
+- -strip $@
+-endif
++ $(CC) $(FSVS_LDFLAGS) $(LDLIBS) $(LIBS) -o $@ $^ $(BASELIBS) $(EXTRALIBS)
+
+
+ # For debugging: generate preprocessed, generate assembler
+@@ -171,7 +161,6 @@
+ .%.d: %.c
+ @echo " deps for $<"
+ @$(CC) $(CPPFLAGS) $(CFLAGS) -MM $< | perl -pe 's#\bdoc.g-c\b##' > $@
+-include $(D_FILES)
+
+ tools/fsvs-chrooter: tools/fsvs-chrooter.c
+ tools/fsvs-chrooter: interface.h config.h
diff --git a/app-admin/fsvs/fsvs-1.2.11.ebuild b/app-admin/fsvs/fsvs-1.2.11.ebuild
new file mode 100644
index 000000000000..20acd526eda7
--- /dev/null
+++ b/app-admin/fsvs/fsvs-1.2.11.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Backup/restore for subversion backends"
+HOMEPAGE="https://github.com/phmarek/fsvs"
+SRC_URI="https://github.com/phmarek/fsvs/archive/refs/tags/${P}.tar.gz"
+S="${WORKDIR}/fsvs-${P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/apr-util
+ dev-libs/libpcre
+ dev-util/ctags
+ dev-vcs/subversion
+ sys-libs/db:*
+ sys-libs/gdbm"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin src/fsvs
+ dodir /etc/fsvs
+ keepdir /var/spool/fsvs
+ doman doc/*5 doc/*1
+ dodoc doc/{FAQ,IGNORING,PERFORMANCE,USAGE}
+}
+
+pkg_postinst() {
+ elog "Remember, this system works best when you're connecting to a remote"
+ elog "svn server."
+ elog
+ elog "Go to the base path for versioning:"
+ elog " cd /"
+ elog "Tell fsvs which URL it should use:"
+ elog " fsvs url svn+ssh://username@machine/path/to/repos"
+ elog "Define ignore patterns - all virtual filesystems (/proc, /sys, etc.),"
+ elog "and (assuming that you're in / currently) the temporary files in /tmp:"
+ elog " fsvs ignore DEVICE:0 ./tmp/*"
+ elog "And you're ready to play!"
+ elog "Check your data in:"
+ elog " fsvs commit -m \"First import\""
+}