summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-02 05:37:21 +0100
committerSam James <sam@gentoo.org>2022-09-02 05:37:27 +0100
commit5908d48769d80baedb730c61b2605a983d97bb0f (patch)
treeecca4a91096b08f8ff02fdd88f5fd79001e32cca
parentmedia-gfx/inkscape: fix build with Poppler 22.09.0 (diff)
downloadgentoo-5908d487.tar.gz
gentoo-5908d487.tar.bz2
gentoo-5908d487.zip
app-office/scribus: fix build with Poppler 22.09.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-office/scribus/files/scribus-1.5.8-poppler-22.09.0.patch20
-rw-r--r--app-office/scribus/scribus-1.5.8-r1.ebuild1
2 files changed, 21 insertions, 0 deletions
diff --git a/app-office/scribus/files/scribus-1.5.8-poppler-22.09.0.patch b/app-office/scribus/files/scribus-1.5.8-poppler-22.09.0.patch
new file mode 100644
index 000000000000..106a6f5162b6
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.5.8-poppler-22.09.0.patch
@@ -0,0 +1,20 @@
+--- a/scribus/plugins/import/pdf/slaoutput.cpp
++++ b/scribus/plugins/import/pdf/slaoutput.cpp
+@@ -3741,9 +3741,16 @@ void SlaOutputDev::getPenState(GfxState *state)
+ break;
+ }
+ double lw = state->getLineWidth();
+- double *dashPattern;
+ int dashLength;
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(22, 9, 0)
++ const double *dashPattern;
++ const std::vector<double> &dash = state->getLineDash(&DashOffset);
++ dashPattern = dash.data();
++ dashLength = dash.size();
++#else
++ double *dashPattern;
+ state->getLineDash(&dashPattern, &dashLength, &DashOffset);
++#endif
+ QVector<double> pattern(dashLength);
+ for (int i = 0; i < dashLength; ++i)
+ {
diff --git a/app-office/scribus/scribus-1.5.8-r1.ebuild b/app-office/scribus/scribus-1.5.8-r1.ebuild
index 5457bc6ee17f..175ae6cd558b 100644
--- a/app-office/scribus/scribus-1.5.8-r1.ebuild
+++ b/app-office/scribus/scribus-1.5.8-r1.ebuild
@@ -80,6 +80,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.5.8-poppler-22.2.0-2.patch
"${FILESDIR}"/${PN}-1.5.8-poppler-22.03.0.patch # bug 834537
"${FILESDIR}"/${PN}-1.5.8-poppler-22.04.0.patch # bug 843287
+ "${FILESDIR}"/${PN}-1.5.8-poppler-22.09.0.patch
)
CMAKE_BUILD_TYPE="Release"