summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-30 21:28:08 +0000
committerSam James <sam@gentoo.org>2021-03-30 21:45:43 +0000
commit591699ea45d46e23808c2286cc060c09e0a83c97 (patch)
treea1178fe7aaf4b1b184b1ccd5a4a142a9772c9634
parentnet-nds/tac_plus: add missing net-libs/libnsl dep (diff)
downloadgentoo-591699ea.tar.gz
gentoo-591699ea.tar.bz2
gentoo-591699ea.zip
net-nds/tac_plus: install PAM configuration file
Thanks-to: Reuben Farrelly <reuben-gentoo-bugzilla@reub.net> Closes: https://bugs.gentoo.org/474860 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-nds/tac_plus/tac_plus-4.0.4.27a-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-nds/tac_plus/tac_plus-4.0.4.27a-r1.ebuild b/net-nds/tac_plus/tac_plus-4.0.4.27a-r1.ebuild
new file mode 100644
index 000000000000..d1efa11dd8b3
--- /dev/null
+++ b/net-nds/tac_plus/tac_plus-4.0.4.27a-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools pam
+
+MY_P="tacacs+-F${PV}"
+DESCRIPTION="An updated version of Cisco's TACACS+ server"
+HOMEPAGE="http://www.shrubbery.net/tac_plus/"
+SRC_URI="ftp://ftp.shrubbery.net/pub/tac_plus/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="HPND RSA GPL-2" # GPL-2 only for init script
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug finger maxsess tcpd skey static-libs"
+
+DEPEND="
+ net-libs/libnsl
+ sys-libs/pam
+ skey? ( >=sys-auth/skey-1.1.5-r1 )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-parallelmake.patch"
+ "${FILESDIR}/${P}-deansification.patch"
+)
+
+src_prepare() {
+ default
+
+ mv configure.in configure.ac || die "Unable to quiet autoconf deprecation warning"
+ AT_M4DIR="." eautoreconf
+
+}
+
+src_configure() {
+ econf \
+ $(use_with skey) \
+ $(use_with tcpd libwrap) \
+ $(use_enable debug) \
+ $(use_enable finger) \
+ $(use_enable maxsess) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use static-libs ; then
+ find "${ED}" -name '*.la' -delete || die "Unable to remove spurious libtool archive"
+ fi
+
+ dodoc CHANGES FAQ
+
+ newinitd "${FILESDIR}/tac_plus.init2" tac_plus
+ newconfd "${FILESDIR}/tac_plus.confd2" tac_plus
+
+ # bug #474860
+ pamd_mimic_system tac_plus auth account password session
+
+ insinto /etc/tac_plus
+ newins "${FILESDIR}/tac_plus.conf2" tac_plus.conf
+}