summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-07 08:02:01 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-07 09:27:42 +0200
commit592428142de0831be28ed910d745b48fe5383ba5 (patch)
tree4799d872a270d4afd677b9d9ac1aea65e215b80a
parentdev-python/cfn-python-lint: Bump to 0.37.1 (diff)
downloadgentoo-59242814.tar.gz
gentoo-59242814.tar.bz2
gentoo-59242814.zip
dev-python/django-otp: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django-otp/Manifest1
-rw-r--r--dev-python/django-otp/django-otp-1.0.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index 5d64f223c3f0..f264f07cb952 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1 +1,2 @@
DIST django-otp-1.0.0.gh.tar.gz 63813 BLAKE2B 17e771f11ddfe4c1667b29da7e6bdbf542796ce48d9f5898e1399603c373bee04a2b6d2d96d8b3295adf07ac245f7e5ad4baf3f6f63f6fe9ce350482a6cc06e8 SHA512 66bce779c5ce98c8b0f64bafa98d8be26a2175678b413bc5e8a80a2157d4b843c217aed7cb7b64fb423184c7dcff5967fa352dd233c404dc51082ec7e94792f7
+DIST django-otp-1.0.1.gh.tar.gz 66717 BLAKE2B 6eb24baf21667af5fe5200a91d320884b1fa37b78def9b543b3411f75de97226d0f40ce53f06391d7cfc9f5ad4020a14e472f9a1abe89844778ef69a2f3b5b72 SHA512 981d374ed4dacf3edd33dc1437465de7458ec243e1ace0b87425ec2b01a51fe4cee3545d1bbe53d7c924c5981b76f7ca77b5da2cf5d6f170f2f7435cff991337
diff --git a/dev-python/django-otp/django-otp-1.0.1.ebuild b/dev-python/django-otp/django-otp-1.0.1.ebuild
new file mode 100644
index 000000000000..3c7f80d1650d
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://github.com/django-otp/django-otp/"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
+}