summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-03 20:03:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-04 11:12:38 +0200
commit5925fa84c3ec3cc95053b33db836d91357b5ba0c (patch)
treedcb39bf73a63d8bf7255537241325f76f4752910
parentx11-wm/herbstclient: remove old (diff)
downloadgentoo-5925fa84.tar.gz
gentoo-5925fa84.tar.bz2
gentoo-5925fa84.zip
dev-ml/ocaml-cstruct: bump to 2.4.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-ml/ocaml-cstruct/Manifest1
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-2.4.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
index 234b05db7c19..3bd8844ee874 100644
--- a/dev-ml/ocaml-cstruct/Manifest
+++ b/dev-ml/ocaml-cstruct/Manifest
@@ -1 +1,2 @@
DIST ocaml-cstruct-2.4.0.tar.gz 259372 SHA256 a3e19e6a57204a5172c9ed0abd5153d85925b2d32f5ae51a53868a287be647fb SHA512 c37d16605f929aeeda33166183dcbe6b8e367583a8b25fde1bb5a4f9141a11f93e6f5463a500907d8829cb285075a8d2ca7874618a92f817997f76258175cbb3 WHIRLPOOL 8812fff7e3cc2a715e8ba395ab852752c0cf28bf8828e61de3f01b52ffabbc61c13c05b03fc964d1f68e88f33ce08c18b44a070881d3b876283fb987b945c664
+DIST ocaml-cstruct-2.4.1.tar.gz 259399 SHA256 f3c1600e85eb93a58c052e2e9575b48d4dd02784d9b2615dadf861860afa1ee7 SHA512 30c541e50dc221d3d8df54f9a8dfa1f88b10f49b276779f7355a38effdfe048de0300bfcc7e361715f63b696d42bd11aa120df6b4058d3b24962777e91b1633e WHIRLPOOL 40d1fcf4674ee47595f14583f964850b4e2b8747f788efb947994ae5b59e12115c381afa7ccc269b408df2b0eed1e02967e83a6fa256aca8926401e6b3e0ed75
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-2.4.1.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-2.4.1.ebuild
new file mode 100644
index 000000000000..36676e8a668e
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-2.4.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ppx"
+
+RDEPEND="
+ async? ( dev-ml/async:= )
+ lwt? ( dev-ml/lwt:= )
+ ppx? (
+ dev-ml/ppx_tools:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_tools_versioned:=
+ )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable lwt)
+ $(use_enable async)
+ $(use_enable ppx)
+ --enable-unix
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )