summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-15 06:24:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-15 06:33:48 +0100
commit5939d19f252cbaca7d5d6ad597e94a59dd8ed8cc (patch)
tree8ae7ec9fbb41231ba214a34f1c269bce26ff55f9
parentnet-ftp/ncftp: fix compilation with clang (diff)
downloadgentoo-5939d19f.tar.gz
gentoo-5939d19f.tar.bz2
gentoo-5939d19f.zip
xfce-base/xfconf: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/xfconf/Manifest1
-rw-r--r--xfce-base/xfconf/xfconf-4.17.0.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/xfce-base/xfconf/Manifest b/xfce-base/xfconf/Manifest
index 6382956b8a43..022d6d2c0f30 100644
--- a/xfce-base/xfconf/Manifest
+++ b/xfce-base/xfconf/Manifest
@@ -1,3 +1,2 @@
DIST xfconf-4.16.0.tar.bz2 634858 BLAKE2B 34a03e457934310d4750b0811ff3b6fbde0c786656c9cc1bb2dd733e0104c2ab3ff1834fefcea31a6711931406b8ab507a528596b598e92c401defb8e6d7715e SHA512 d2e6b272243d6eda71f42cb3df18cb9c0745a1864718639e9aa494902dfe5b4989b2761fee2195456e5725cad0f744978f9c95c6f01e48aa016a919ce3468344
-DIST xfconf-4.17.0.tar.bz2 629001 BLAKE2B f7dbddc5762e4000a1cd5de4c02656f2a1626a244c847f53d1d0646773d91b2a10ee48e870d4b42bd004756e09a9b1e3d3e22f240712e5e7c9fe759908ece048 SHA512 e1eac703a898f151d9bde6c4177103498754a776b0c7f1381e7af9994a9cb1765943f840b31e665f40a1c4a26bc8b8a0c6e8aa0615f5501a52d4860065d59bc3
DIST xfconf-4.17.1.tar.bz2 624819 BLAKE2B a8752240b6619c9be83b73c16e1bb4915853b728aeb168d803f569dc38f221d5a02d2d1cbf8eee7ea43dd37f6473de5b6ec30848bf1f502bdc974002edcde681 SHA512 c0d5d3b41a9194390b0d45705a496a37bb55c7dd8821efcbad06e0e37ccfd917c4a54de45be16820c20748df81c1aee47cbec2c27caa1eaa5007802f87848762
diff --git a/xfce-base/xfconf/xfconf-4.17.0.ebuild b/xfce-base/xfconf/xfconf-4.17.0.ebuild
deleted file mode 100644
index 4e3f29b8703c..000000000000
--- a/xfce-base/xfconf/xfconf-4.17.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 vala
-
-DESCRIPTION="A configuration management system for Xfce"
-SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
-HOMEPAGE="
- https://docs.xfce.org/xfce/xfconf/start
- https://gitlab.xfce.org/xfce/xfconf/
-"
-
-LICENSE="GPL-2+"
-SLOT="0/3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
-IUSE="debug +introspection vala"
-REQUIRED_USE="vala? ( introspection )"
-
-DEPEND="
- >=dev-libs/glib-2.50
- sys-apps/dbus
- >=xfce-base/libxfce4util-4.14:=
- introspection? ( >=dev-libs/gobject-introspection-1.66:= )
- !<xfce-base/xfce4-panel-4.13.1
- !<xfce-base/xfce4-settings-4.13.1
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-util/gdbus-codegen
- dev-util/glib-utils
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig
- vala? ( $(vala_depend) )
-"
-
-src_configure() {
- local myconf=(
- $(use_enable introspection)
- $(use_enable vala)
- $(use_enable debug checks)
- --with-bash-completion-dir="$(get_bashcompdir)"
- )
-
- use vala && vala_setup
- econf "${myconf[@]}"
-}
-
-src_test() {
- local service_dir=${HOME}/.local/share/dbus-1/services
- mkdir -p "${service_dir}" || die
- cat > "${service_dir}/org.xfce.Xfconf.service" <<-EOF || die
- [D-BUS Service]
- Name=org.xfce.Xfconf
- Exec=${S}/xfconfd/xfconfd
- EOF
-
- (
- # start isolated dbus session bus
- dbus_data=$(dbus-launch --sh-syntax) || exit
- eval "${dbus_data}"
-
- # -j>1 often hangs
- # https://gitlab.xfce.org/xfce/xfconf/-/issues/13
- nonfatal emake -j1 check
- ret=${?}
-
- kill "${DBUS_SESSION_BUS_PID}"
- exit "${ret}"
- ) || die
-}
-
-src_install() {
- default
- find "${D}" -type f -name '*.la' -delete || die
-}