summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-04-27 14:49:30 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-04-27 14:49:46 -0400
commit5943364a32b99764a4b2527ab32b14d7e1476d57 (patch)
treecb70153993803db608c3fb0dc6c274065d53b5b8
parentapp-office/libreoffice: Drop 5.2.3.3 (diff)
downloadgentoo-5943364a32b99764a4b2527ab32b14d7e1476d57.tar.gz
gentoo-5943364a32b99764a4b2527ab32b14d7e1476d57.tar.bz2
gentoo-5943364a32b99764a4b2527ab32b14d7e1476d57.zip
x11-plugins/allin1: new EAPI=6 revision.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--x11-plugins/allin1/allin1-0.5.0-r2.ebuild (renamed from x11-plugins/allin1/allin1-0.5.0-r1.ebuild)10
-rw-r--r--x11-plugins/allin1/files/makefile-r2.patch23
2 files changed, 27 insertions, 6 deletions
diff --git a/x11-plugins/allin1/allin1-0.5.0-r1.ebuild b/x11-plugins/allin1/allin1-0.5.0-r2.ebuild
index 2afa15eba169..0721c811d6b3 100644
--- a/x11-plugins/allin1/allin1-0.5.0-r1.ebuild
+++ b/x11-plugins/allin1/allin1-0.5.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="All in one monitoring dockapp: RAM, CPU, Net, Power, df, seti"
HOMEPAGE="http://ilpettegolo.altervista.org/linux_allin1.en.shtml"
@@ -20,9 +20,7 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-proto/xproto"
-src_prepare() {
- epatch "${FILESDIR}/makefile.patch"
-}
+PATCHES=( "${FILESDIR}/makefile-r2.patch" )
src_compile() {
emake \
diff --git a/x11-plugins/allin1/files/makefile-r2.patch b/x11-plugins/allin1/files/makefile-r2.patch
new file mode 100644
index 000000000000..9d0b2ab028fa
--- /dev/null
+++ b/x11-plugins/allin1/files/makefile-r2.patch
@@ -0,0 +1,23 @@
+--- a/src/Makefile.old 2012-10-24 13:12:48.128285694 +0200
++++ b/src/Makefile 2012-10-24 13:19:56.135247071 +0200
+@@ -11,8 +11,9 @@
+
+ CC = gcc
+ FLEX = flex
+-LIBFLAGS = -ggdb -Wall -O2 -fPIC
+-CFLAGS = -ggdb -Wall -O2
++LIBFLAGS = -fPIC
++CFLAGS =
++LDFLAGS =
+ GENERATED = allin1 confparse.c
+ LIBRARIES = -L/usr/X11R6/lib -lXext -lX11 -lXpm -lm
+ MODULES = allin1.o dockhelper.o memory.o battery.o cpu.o \
+@@ -58,7 +59,7 @@
+
+
+ allin1: $(MODULES)
+- $(CC) $(CFLAGS) -o $@ $(MODULES) -DDEBUG $(LIBRARIES)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(MODULES) -DDEBUG $(LIBRARIES)
+
+
+ install: allin1