summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-01 22:30:01 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-01 22:30:37 +0100
commit594e1fa02a7480fba3a27f2885d9f1ad188233d4 (patch)
tree3322fd8b5263daaa621b6687141725f27bc225f6
parentmedia-gfx/hydrus: Add 463, remove 459.3 (diff)
downloadgentoo-594e1fa0.tar.gz
gentoo-594e1fa0.tar.bz2
gentoo-594e1fa0.zip
dev-python/nest_asyncio: Bump to 1.5.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nest_asyncio/Manifest1
-rw-r--r--dev-python/nest_asyncio/nest_asyncio-1.5.4.ebuild17
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/nest_asyncio/Manifest b/dev-python/nest_asyncio/Manifest
index ffc3aa622cc0..47a5a97139b0 100644
--- a/dev-python/nest_asyncio/Manifest
+++ b/dev-python/nest_asyncio/Manifest
@@ -1,2 +1,3 @@
DIST nest_asyncio-1.5.1.tar.gz 5738 BLAKE2B 0aa7d9a71c75b97b1eeb40dab8b2b9942a6c2107643aa82429b3d27c3fcc3602494a86903669ec3ee4f577802463cdf05cfafc4bf0c6721b251a61b079d7381a SHA512 cb85ce82706d17081de58e4176bbc6bba9efd9eec99a36902dd689010d08d4267e742cabb89c088cc274aac13ed9929f09e0f55f375cee35e3c15385ed2fe0d3
DIST nest_asyncio-1.5.2.tar.gz 7227 BLAKE2B a6e57f10f7fdeed0e141dad40bf170d8e3194712c9b458666188508594dabadbac73e60d6ef0c6669fea8dab7f8f05b94e66646f4783440edf511c64ea152739 SHA512 089fc6ef6b8c029426dab2036b6817281a18e137fe54ce7275caa8eeb25acc3ce513d493d8257ddd0b0219cb999a0b6d9c65ca2798efb525cea469873e98e712
+DIST nest_asyncio-1.5.4.tar.gz 5893 BLAKE2B d3f693e251d5f0e9f7f31e0aa3e88962aaf927320268a31d53fc2b2eb71bb45eb3a8f9d7f733d0ca96a848beb1d8c505121325749226e962a44b3c2988873190 SHA512 982e274712ec8a8004108492708f28fbf459c5f2d274e754387b0afa0f92425fe29be075e3402bbc319accf17974efcbb3015799421f6a10ed15cfa424f82310
diff --git a/dev-python/nest_asyncio/nest_asyncio-1.5.4.ebuild b/dev-python/nest_asyncio/nest_asyncio-1.5.4.ebuild
new file mode 100644
index 000000000000..be2f4e2dd502
--- /dev/null
+++ b/dev-python/nest_asyncio/nest_asyncio-1.5.4.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Patch asyncio to allow nested event loops"
+HOMEPAGE="https://github.com/erdewit/nest_asyncio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest