summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-10-16 20:09:36 +0200
committerMatt Turner <mattst88@gentoo.org>2022-10-29 14:33:58 -0400
commit59559fd230babde48e08401fe12b601604b42937 (patch)
tree90f40a32cc3e8d6ad01fdd251a20e4800cced991
parentapp-office/planner: disable eds, fix QA (diff)
downloadgentoo-59559fd2.tar.gz
gentoo-59559fd2.tar.bz2
gentoo-59559fd2.zip
app-office/planner: add live ebuild, use meson
This ebuild already drops the gnome-base/gconf dep, once there is a new release from upstream, remove the old ebuild and close Bug: https://bugs.gentoo.org/873853 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/27800 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-office/planner/metadata.xml3
-rw-r--r--app-office/planner/planner-9999.ebuild71
2 files changed, 74 insertions, 0 deletions
diff --git a/app-office/planner/metadata.xml b/app-office/planner/metadata.xml
index c6e394b17a27..3a8e42950cb7 100644
--- a/app-office/planner/metadata.xml
+++ b/app-office/planner/metadata.xml
@@ -5,4 +5,7 @@
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
+ <use>
+ <flag name="libgda">Database/GDA support</flag>
+ </use>
</pkgmetadata>
diff --git a/app-office/planner/planner-9999.ebuild b/app-office/planner/planner-9999.ebuild
new file mode 100644
index 000000000000..b3239ac6b40b
--- /dev/null
+++ b/app-office/planner/planner-9999.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Project manager for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Planner"
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/World/planner.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+fi
+
+SLOT="0"
+LICENSE="GPL-2+"
+IUSE="examples gtk-doc libgda" # eds
+
+RDEPEND="
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3
+ >=dev-libs/libxml2-2.6.27:2
+ >=dev-libs/libxslt-1.1.23
+ libgda? ( >=gnome-extra/libgda-1.0:5 )
+"
+ # eds support is broken for now
+ # eds? (
+ # >=gnome-extra/evolution-data-server-3.6:=
+ # )
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ gtk-doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature libgda database-gda)
+ # $(meson_feature eds)
+ -Deds=disabled # upstream says it's broken
+ $(meson_use examples)
+ $(meson_use gtk-doc gtk_doc)
+ -Dsimple-priority-scheduling=false # upstream says it's experimental
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use examples; then
+ mv "${ED}"/usr/share/doc/planner "${ED}"/usr/share/doc/${PF} || die
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}