summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-01 06:41:57 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-01 07:16:15 +0100
commit595f340b39a398850d06d308365f9d90133f7c77 (patch)
tree1d1fb77f40c2a6b033b3d680494fcce9ace13b59
parentapp-admin/awscli: Bump to 1.27.81 (diff)
downloadgentoo-595f340b39a398850d06d308365f9d90133f7c77.tar.gz
gentoo-595f340b39a398850d06d308365f9d90133f7c77.tar.bz2
gentoo-595f340b39a398850d06d308365f9d90133f7c77.zip
dev-python/ubelt: Bump to 1.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ubelt/Manifest1
-rw-r--r--dev-python/ubelt/ubelt-1.2.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/ubelt/Manifest b/dev-python/ubelt/Manifest
index 3dede266efe1..e2edda34e53e 100644
--- a/dev-python/ubelt/Manifest
+++ b/dev-python/ubelt/Manifest
@@ -1 +1,2 @@
DIST ubelt-1.2.3.gh.tar.gz 324632 BLAKE2B bafb67048a8a6525fc0aa1393fff22a3bf56d3843d195dc29125b8f452c4700dff77282349fbb44e0fc23a5495bcf48d6626879603f6c68a14ee04435d0f1831 SHA512 2a0a3e8b40ebaa5d2c7856cd197cdd8113ff58be6827ce57f394284f824e310078ef2a754247575c9eec2d3d1eecce2ec22239102eade025d556a79552e5f9d3
+DIST ubelt-1.2.4.gh.tar.gz 337670 BLAKE2B 4c8b1c05cbed0f28e69b43445f12881e4c619be4a513b9263a6eb4d674e56b0a869d1e78072e1e89a505a12b3b40dddbb48424bccdcfbae1a7eabf7746bc79d0 SHA512 5fbe36598a035d1504b24a06e8f0fcd1c9d0ccc238f81bfad582288aced9ebc8323e7acf2705d47e60f36513cbf665051f554cce122d75d55247b5fc122af419
diff --git a/dev-python/ubelt/ubelt-1.2.4.ebuild b/dev-python/ubelt/ubelt-1.2.4.ebuild
new file mode 100644
index 000000000000..1900b772e9f4
--- /dev/null
+++ b/dev-python/ubelt/ubelt-1.2.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A stdlib like feel, and extra batteries. Hashing, Caching, Timing, Progress"
+HOMEPAGE="
+ https://github.com/Erotemic/ubelt/
+ https://pypi.org/project/ubelt/
+"
+SRC_URI="
+ https://github.com/Erotemic/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ dev-python/xdoctest[${PYTHON_USEDEP}]
+ >=dev-python/xxhash-1.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_editable_modules.py::test_import_of_editable_install
+ # relies on passwd home being equal to ${HOME}
+ ubelt/util_path.py::userhome:0
+)