summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-23 14:35:26 +0100
committerSam James <sam@gentoo.org>2023-05-30 19:04:11 +0100
commit596a3db48e5114d8d3461b5373985ced8eef85ff (patch)
treeb7dee317cfbcb75157fc0307f993cb90c7135ef7
parentmedia-plugins/gst-plugins-gtk: add 1.22.3 (diff)
downloadgentoo-596a3db48e5114d8d3461b5373985ced8eef85ff.tar.gz
gentoo-596a3db48e5114d8d3461b5373985ced8eef85ff.tar.bz2
gentoo-596a3db48e5114d8d3461b5373985ced8eef85ff.zip
media-plugins/gst-plugins-hls: add 1.22.3
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-plugins/gst-plugins-hls/Manifest1
-rw-r--r--media-plugins/gst-plugins-hls/gst-plugins-hls-1.22.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-hls/Manifest b/media-plugins/gst-plugins-hls/Manifest
index c06a8695481f..be652e5ab7de 100644
--- a/media-plugins/gst-plugins-hls/Manifest
+++ b/media-plugins/gst-plugins-hls/Manifest
@@ -1,3 +1,4 @@
DIST gst-plugins-bad-1.20.3.tar.xz 6222824 BLAKE2B 01aae59adbe76b8e50a49fb8bb8037e6f3aa93cbc2b658aab05ebbf30f8d1aef98c1981712caa39e3c9d08f1e0c9d76f2f874f7d2fdd994b3a0735b2809eafdf SHA512 cfcf126eabff550455decd7054a269b73489708c10a6b6090dddb5fde29bfba07ed330c339927ff170e025fa3a08d2ffb822322dc3798679366207a54132c71b
DIST gst-plugins-bad-1.20.4.tar.xz 6229992 BLAKE2B 2cd276cec9991e2ca7367a43024d7aee43adaa185a4a06ec08d1e736e72333f7f38cb54257120b9a313feb1fdc285a50d456b4c1fb33627d83acfcd3ece20687 SHA512 31b28d4a1bbecf021a90f2aa49dd344ccea12533b65f3bf3a8426ca2175469fff7b7f8e08af7d3d22c18db2fe48b9d5fbea2b325d296aee04b019cebef1eaec4
DIST gst-plugins-bad-1.20.5.tar.xz 6237720 BLAKE2B bf379da420d1f7f148cf51373f6f2d0800685487c8bdb7a768e79e0a2e4f1721053922be9321958b4ce318de12ea390de4cd89c345329ac41dd0425815e0e7f6 SHA512 4b4603d755d17a0fa072d771521bdcbf554fc9abdc8105b9d9189062e5725ae2989f430e1de77363a69d8c969ecbf15e73e9c478fabe8efac83b2d9b1b0a4a0a
+DIST gst-plugins-bad-1.22.3.tar.xz 5523924 BLAKE2B 8015098ac2d19546de58cebdbe29fd7fbb2c7f076bf775564d7b862ed99a59968a2f751ff1137534d178fea5cf1c2022e53e4159ca2e5d3bf71c9fa4663be4f5 SHA512 1512e26111174ea4a9da26203a635e7ec7673ea5b6ca8dae8aaa8a20ffae36c9b68904d669344a8efc31f751093a00e22d2a1f1affcdd037f162493441c77628
diff --git a/media-plugins/gst-plugins-hls/gst-plugins-hls-1.22.3.ebuild b/media-plugins/gst-plugins-hls/gst-plugins-hls-1.22.3.ebuild
new file mode 100644
index 000000000000..3c9a8d7e2f5c
--- /dev/null
+++ b/media-plugins/gst-plugins-hls/gst-plugins-hls-1.22.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer-meson
+
+DESCRIPTION="HTTP live streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/nettle:0=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/gst-plugins-bad-1.18.4-use-system-libs-hls.patch
+)
+
+src_prepare() {
+ default
+ gstreamer_system_library gstadaptivedemux_dep:gstadaptivedemux
+ gstreamer_system_package pbutils_dep:gstreamer-pbutils
+ gstreamer_system_package tag_dep:gstreamer-tag
+ gstreamer_system_package video_dep:gstreamer-video
+ gstreamer_system_library gsturidownloader_dep:gsturidownloader
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dhls-crypto=nettle
+ )
+
+ gstreamer_multilib_src_configure
+}