summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-22 21:09:56 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-22 21:16:12 +0100
commit596af86fabaf72c8e712f16348212d87dc4d4ab3 (patch)
tree9a33b693e356f5700228bbe23158e6feeeae70bf
parentapp-emacs/emacs-el-fetch: new package; add 3.2.1 (diff)
downloadgentoo-596af86fabaf72c8e712f16348212d87dc4d4ab3.tar.gz
gentoo-596af86fabaf72c8e712f16348212d87dc4d4ab3.tar.bz2
gentoo-596af86fabaf72c8e712f16348212d87dc4d4ab3.zip
app-emacs/emacs-websearch: new package; add 2.0.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/emacs-websearch/Manifest1
-rw-r--r--app-emacs/emacs-websearch/emacs-websearch-2.0.1.ebuild29
-rw-r--r--app-emacs/emacs-websearch/emacs-websearch-9999.ebuild29
-rw-r--r--app-emacs/emacs-websearch/metadata.xml23
4 files changed, 82 insertions, 0 deletions
diff --git a/app-emacs/emacs-websearch/Manifest b/app-emacs/emacs-websearch/Manifest
new file mode 100644
index 000000000000..2c55ae214d8c
--- /dev/null
+++ b/app-emacs/emacs-websearch/Manifest
@@ -0,0 +1 @@
+DIST emacs-websearch-2.0.1.tar.bz2 93918 BLAKE2B ec7a1c03b8b04d6fd48f56a774e69d962536fb7add843533b554099349638e4223ceb2cf37f89d68589292efe6388b4bce9b31b9100b73ced0dbc540cf8fcc21 SHA512 c6815be855b887943315f96e880a566b38c91da3c88b6077c3845d96aa35c0ea33af32ae9224f9efeb8d8b49c0cbb5bc08dfaade1659d1fc85ed44aecaa371ff
diff --git a/app-emacs/emacs-websearch/emacs-websearch-2.0.1.ebuild b/app-emacs/emacs-websearch/emacs-websearch-2.0.1.ebuild
new file mode 100644
index 000000000000..8a88f1199ed5
--- /dev/null
+++ b/app-emacs/emacs-websearch/emacs-websearch-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Query search engines from Emacs"
+HOMEPAGE="https://gitlab.com/xgqt/emacs-websearch/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/xgqt/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/xgqt/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOCS=( README.md logo.png )
+
+src_install() {
+ elisp_src_install
+ elisp-site-file-install "${S}"/extras/gentoo/50websearch-gentoo.el
+}
diff --git a/app-emacs/emacs-websearch/emacs-websearch-9999.ebuild b/app-emacs/emacs-websearch/emacs-websearch-9999.ebuild
new file mode 100644
index 000000000000..8a88f1199ed5
--- /dev/null
+++ b/app-emacs/emacs-websearch/emacs-websearch-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Query search engines from Emacs"
+HOMEPAGE="https://gitlab.com/xgqt/emacs-websearch/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/xgqt/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/xgqt/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOCS=( README.md logo.png )
+
+src_install() {
+ elisp_src_install
+ elisp-site-file-install "${S}"/extras/gentoo/50websearch-gentoo.el
+}
diff --git a/app-emacs/emacs-websearch/metadata.xml b/app-emacs/emacs-websearch/metadata.xml
new file mode 100644
index 000000000000..3dc420dbd6ef
--- /dev/null
+++ b/app-emacs/emacs-websearch/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ The websearch package allows You to query predefined search engines
+ (websearch-custom-engines) with interactive selection. The query terms can
+ either be extracted form selection, kill-ring or typed on demand.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <maintainer status="active">
+ <email>xgqt@riseup.net</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <bugs-to>https://gitlab.com/xgqt/emacs-websearch/-/issues/</bugs-to>
+ <remote-id type="gitlab">xgqt/emacs-websearch</remote-id>
+ </upstream>
+</pkgmetadata>