summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2019-06-11 08:25:59 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2019-06-11 08:35:10 -0700
commit59768d41256b5eda384f6b9f50b8ecc3b91bf214 (patch)
tree49097931aa77ccf22e301bf5e9c8ea585e3146e3
parentsys-apps/iproute2: musl compilefix (diff)
downloadgentoo-59768d41256b5eda384f6b9f50b8ecc3b91bf214.tar.gz
gentoo-59768d41256b5eda384f6b9f50b8ecc3b91bf214.tar.bz2
gentoo-59768d41256b5eda384f6b9f50b8ecc3b91bf214.zip
dev-vcs/git: fix git-subtree.1 build failure
Partial revert of commit 56312573763e794982d7a7284e7e7d1a8a9f8eaa Some of the manpages require the full documentation stack. Documentation build is gated behind USE=doc due to the dependencies, so move the manpage behind the conditional as well. As a future action, ask upstream to include git-subtree.1 with the rest of the prebuilt Documentation. Fixes: https://bugs.gentoo.org/687848 See-Also: https://bugs.gentoo.org/517794 Package-Manager: Portage-2.3.67, Repoman-2.3.12 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--dev-vcs/git/git-2.22.0.ebuild10
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild10
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild10
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild10
-rw-r--r--dev-vcs/git/git-9999.ebuild10
5 files changed, 30 insertions, 20 deletions
diff --git a/dev-vcs/git/git-2.22.0.ebuild b/dev-vcs/git/git-2.22.0.ebuild
index 64663fba9b78..42969a491fbf 100644
--- a/dev-vcs/git/git-2.22.0.ebuild
+++ b/dev-vcs/git/git-2.22.0.ebuild
@@ -384,8 +384,9 @@ src_compile() {
fi
pushd contrib/subtree &>/dev/null || die
- git_emake git-subtree{,.1}
- use doc && git_emake git-subtree.html
+ git_emake git-subtree
+ # git-subtree.1 requires the full USE=doc dependency stack
+ use doc && git_emake git-subtree.html git-subtree.1
popd &>/dev/null || die
pushd contrib/diff-highlight &>/dev/null || die
@@ -451,9 +452,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install install-man || die "Failed to emake install install-man git-subtree"
+ git_emake install || die "Failed to emake install for git-subtree"
if use doc ; then
- git_emake install-html || die "Failed to emake install-html git-subtree"
+ # Do not move git subtree install-man outside USE=doc!
+ git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 64663fba9b78..42969a491fbf 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -384,8 +384,9 @@ src_compile() {
fi
pushd contrib/subtree &>/dev/null || die
- git_emake git-subtree{,.1}
- use doc && git_emake git-subtree.html
+ git_emake git-subtree
+ # git-subtree.1 requires the full USE=doc dependency stack
+ use doc && git_emake git-subtree.html git-subtree.1
popd &>/dev/null || die
pushd contrib/diff-highlight &>/dev/null || die
@@ -451,9 +452,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install install-man || die "Failed to emake install install-man git-subtree"
+ git_emake install || die "Failed to emake install for git-subtree"
if use doc ; then
- git_emake install-html || die "Failed to emake install-html git-subtree"
+ # Do not move git subtree install-man outside USE=doc!
+ git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 64663fba9b78..42969a491fbf 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -384,8 +384,9 @@ src_compile() {
fi
pushd contrib/subtree &>/dev/null || die
- git_emake git-subtree{,.1}
- use doc && git_emake git-subtree.html
+ git_emake git-subtree
+ # git-subtree.1 requires the full USE=doc dependency stack
+ use doc && git_emake git-subtree.html git-subtree.1
popd &>/dev/null || die
pushd contrib/diff-highlight &>/dev/null || die
@@ -451,9 +452,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install install-man || die "Failed to emake install install-man git-subtree"
+ git_emake install || die "Failed to emake install for git-subtree"
if use doc ; then
- git_emake install-html || die "Failed to emake install-html git-subtree"
+ # Do not move git subtree install-man outside USE=doc!
+ git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 64663fba9b78..42969a491fbf 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -384,8 +384,9 @@ src_compile() {
fi
pushd contrib/subtree &>/dev/null || die
- git_emake git-subtree{,.1}
- use doc && git_emake git-subtree.html
+ git_emake git-subtree
+ # git-subtree.1 requires the full USE=doc dependency stack
+ use doc && git_emake git-subtree.html git-subtree.1
popd &>/dev/null || die
pushd contrib/diff-highlight &>/dev/null || die
@@ -451,9 +452,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install install-man || die "Failed to emake install install-man git-subtree"
+ git_emake install || die "Failed to emake install for git-subtree"
if use doc ; then
- git_emake install-html || die "Failed to emake install-html git-subtree"
+ # Do not move git subtree install-man outside USE=doc!
+ git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 9a03288ee8b7..bf2df79b8abc 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -384,8 +384,9 @@ src_compile() {
fi
pushd contrib/subtree &>/dev/null || die
- git_emake git-subtree{,.1}
- use doc && git_emake git-subtree.html
+ git_emake git-subtree
+ # git-subtree.1 requires the full USE=doc dependency stack
+ use doc && git_emake git-subtree.html git-subtree.1
popd &>/dev/null || die
pushd contrib/diff-highlight &>/dev/null || die
@@ -451,9 +452,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install install-man || die "Failed to emake install install-man git-subtree"
+ git_emake install || die "Failed to emake install for git-subtree"
if use doc ; then
- git_emake install-html || die "Failed to emake install-html git-subtree"
+ # Do not move git subtree install-man outside USE=doc!
+ git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt