summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-06-11 15:55:36 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2016-06-11 15:59:13 +0300
commit597c3171bdc822183a04ff1805b9349c137e0ec3 (patch)
tree79f8ab75224473eab97283264d8eec5a2ff37ac1
parentnet-misc/openssh: Security cleanup (bug #571892). (diff)
downloadgentoo-597c3171bdc822183a04ff1805b9349c137e0ec3.tar.gz
gentoo-597c3171bdc822183a04ff1805b9349c137e0ec3.tar.bz2
gentoo-597c3171bdc822183a04ff1805b9349c137e0ec3.zip
dev-libs/cryptlib: version bump
Bug: 585008 Package-Manager: portage-2.2.28
-rw-r--r--dev-libs/cryptlib/Manifest1
-rw-r--r--dev-libs/cryptlib/cryptlib-3.4.3.ebuild130
-rw-r--r--dev-libs/cryptlib/files/cryptlib-3.4.3-build.patch54
-rw-r--r--dev-libs/cryptlib/files/cryptlib-3.4.3-zlib.patch55
4 files changed, 240 insertions, 0 deletions
diff --git a/dev-libs/cryptlib/Manifest b/dev-libs/cryptlib/Manifest
index 1fd4be63327b..b624a48f11c4 100644
--- a/dev-libs/cryptlib/Manifest
+++ b/dev-libs/cryptlib/Manifest
@@ -1,2 +1,3 @@
DIST cl340.zip 5514751 SHA256 fff4cca9e70e579763882cd58bc8a5b36c52c20a7ace6c8b21c5e4e9e05fd9d5 SHA512 b9091ee4ce589f95ce479a0de25c5456db18d955350cc245637addf31f3c03cfe87c971f5a7bff274d17451059d319723cd337cb25a672e0823e29b98b4b87f8 WHIRLPOOL 8965d0c6b0e0bd38d0bbf674a75ac43ea7ea482218c6592d51d0baa7a6ff8673a27c8095084dc7d7cbca39c29bc9acdb6351d6a1f64f6cdc6c1bf906b2579cff
+DIST cl343.zip 5703258 SHA256 08b104442bb5c7281a3299853d5585cc63bd928454dff3150569c02b957427ad SHA512 abbd53c00be82749f7e359f22cd45ef2b1d90040427457ee8d452d2b513093789b99fa8e904b8a7c75e8db046c59d96e966ce64c2b3630bd21cf3e91b57bc58a WHIRLPOOL 0e1f9dd18172ac9ba244845147e7da41932ea13099aa94957b090be2eb302f179a96bb64c04ddcb74f21cdf5be0c6ed849df4076eb77cbde912719a73ffb1b26
DIST cryptlib-3.4.0-manual.pdf.bz2 1215921 SHA256 b06b736e6e123f578adcd08a8ede6cdb62e3e6d4ac2decb3570def1b29d44da8 SHA512 dbf9914a110a686dc23fedd23c16cefbae12cc67e378db67ac292f8f782b3b615a5819013f2b9c4861086c7ddfab690db9d68a911346102def323255cf48069b WHIRLPOOL 8cc64ab7ffe8a97714e793dd3dfe36708e7e2c7ec583479c593d767de22b860be5bcf0a70427f6f2e7e1d9732ec4ba2d2b3f1617f97bb649c0298924e4a93fb6
diff --git a/dev-libs/cryptlib/cryptlib-3.4.3.ebuild b/dev-libs/cryptlib/cryptlib-3.4.3.ebuild
new file mode 100644
index 000000000000..a0078b8ddf0e
--- /dev/null
+++ b/dev-libs/cryptlib/cryptlib-3.4.3.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+DISTUTILS_OPTIONAL=1
+
+inherit distutils-r1 eutils flag-o-matic multilib toolchain-funcs versionator
+
+MY_PV="${PV//.}"
+
+DESCRIPTION="Powerful security toolkit for adding encryption to software"
+HOMEPAGE="http://www.cs.auckland.ac.nz/~pgut001/cryptlib/"
+DOC_PREFIX="${PN}-$(get_version_component_range 1-2 ${PV}).0"
+SRC_URI="ftp://ftp.franken.de/pub/crypt/cryptlib/cl${MY_PV}.zip
+ doc? ( mirror://gentoo/${DOC_PREFIX}-manual.pdf.bz2 )"
+
+LICENSE="Sleepycat"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc ldap odbc python"
+
+S="${WORKDIR}"
+
+RDEPEND="sys-libs/zlib
+ ldap? ( net-nds/openldap )
+ odbc? ( dev-db/unixODBC )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+ # we need the -a option, so we can not use 'unpack'
+ unzip -qoa "${DISTDIR}/cl${MY_PV}.zip" || die
+ use doc && unpack "${DOC_PREFIX}-manual.pdf.bz2"
+}
+
+wrap_python() {
+ if use python; then
+ cd bindings || die
+ distutils-r1_${1}
+ fi
+}
+
+src_prepare() {
+ rm -fr zlib || die
+
+ # we want our own CFLAGS ;-)
+ sed -i -e "s:-m.*=pentium::g" -e "s:-fomit-frame-pointer::g" -e "s:-O2::g" \
+ -e "s:-O3::g" -e "s:-O4::g" makefile || die "sed makefile failed"
+ sed -i -e "s/-march=[[:alnum:]\.=-]*//g" -e "s/-mcpu=[[:alnum:]\.=-]*//g" \
+ -e "s:-O2::g" -e "s:-O3::g" tools/ccopts.sh || die "sed tools/ccopts.sh failed"
+
+ # change 'make' to '$(MAKE)'
+ sed -i -e "s:@\?make:\$(MAKE):g" makefile || die "sed makefile failed"
+
+ # NOTICE:
+ # Because of stack execution
+ # assembly parts are disabled.
+ sed -i -e 's:i\[3,4,5,6\]86:___:g' makefile || die "sed makefile failed"
+
+ # Fix version number of shared library.
+ sed -i -e 's/PLV="2"/PLV="3"/' tools/buildall.sh || die "sed tools/buildall.sh failed"
+
+ # Respect LDFLAGS and fix soname and strip issues.
+ epatch "${FILESDIR}/${P}-build.patch"
+
+ # Use external zlib.
+ epatch "${FILESDIR}/${P}-zlib.patch"
+
+ wrap_python ${FUNCNAME}
+}
+
+src_compile() {
+ local libname="libcl.so.${PV}"
+
+ # At least -O2 is needed.
+ replace-flags -O -O2
+ replace-flags -O0 -O2
+ replace-flags -O1 -O2
+ replace-flags -Os -O2
+ is-flagq -O* || append-flags -O2
+
+ append-flags "-fPIC -D__UNIX__ -DOSVERSION=2 -DNDEBUG -I."
+
+ if [ -f /usr/include/pthread.h -a \
+ `grep -c PTHREAD_MUTEX_RECURSIVE /usr/include/pthread.h` -ge 0 ] ; then
+ append-flags "-DHAS_RECURSIVE_MUTEX"
+ fi
+ if [ -f /usr/include/pthread.h -a \
+ `grep -c PTHREAD_MUTEX_ROBUST /usr/include/pthread.h` -ge 0 ] ; then
+ append-flags "-DHAS_ROBUST_MUTEX"
+ fi
+
+ use ldap && append-flags -DHAS_LDAP
+ use odbc && append-flags -DHAS_ODBC
+
+ emake directories
+ emake toolscripts
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -c" STRIP=true Linux
+
+ emake TARGET=${libname} OBJPATH="./shared-obj/" CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -c" STRIP=true Linux
+
+ if use python; then
+ #ln -s libcl.so.${PV} libcl.so || die
+
+ # Python bindings don't work with -O2 and higher.
+ replace-flags -O* -O1
+
+ wrap_python ${FUNCNAME}
+ fi
+}
+
+src_install() {
+ dolib.so "libcl.so.${PV}"
+ dosym "libcl.so.${PV}" "/usr/$(get_libdir)/libcl.so"
+ dolib.a "libcl.a"
+
+ doheader cryptlib.h
+
+ dodoc README
+ if use doc; then
+ newdoc "${DOC_PREFIX}-manual.pdf" "manual.pdf"
+ fi
+
+ wrap_python ${FUNCNAME}
+}
diff --git a/dev-libs/cryptlib/files/cryptlib-3.4.3-build.patch b/dev-libs/cryptlib/files/cryptlib-3.4.3-build.patch
new file mode 100644
index 000000000000..309d73230cfb
--- /dev/null
+++ b/dev-libs/cryptlib/files/cryptlib-3.4.3-build.patch
@@ -0,0 +1,54 @@
+From 58d3e56f59e0e8d48d913c217929b35e9366e829 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 11 Jun 2016 15:07:12 +0300
+Subject: [PATCH] build: so: support LDFLAGS and SONAME
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ tools/buildsharedlib.sh | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tools/buildsharedlib.sh b/tools/buildsharedlib.sh
+index f1277a7..59c4713 100644
+--- a/tools/buildsharedlib.sh
++++ b/tools/buildsharedlib.sh
+@@ -131,9 +131,9 @@ case $OSNAME in
+ *)
+ if [ `$LD -v 2>&1 | grep -c gcc` -gt 0 -a \
+ `gcc -Wl,-Bsymbolic 2>&1 | grep -c unrecognized` = 0 ] ; then
+- $LD -shared -Wl,-Bsymbolic -o $LIBNAME `cat $LINKFILE` `./tools/getlibs.sh autodetect` ;
++ $LD -shared $LDFLAGS -Wl,-soname,$LIBNAME -Wl,-Bsymbolic -o $LIBNAME `cat $LINKFILE` `./tools/getlibs.sh autodetect` ;
+ else
+- $LD -shared -o $LIBNAME `cat $LINKFILE` `./tools/getlibs.sh autodetect` ;
++ $LD -shared -shared $LDFLAGS -Wl,-soname,$LIBNAME -o $LIBNAME `cat $LINKFILE` `./tools/getlibs.sh autodetect` ;
+ fi
+ if [ `which objdump` -a `objdump -p $LIBNAME | grep -c TEXTREL` -gt '0' ] ; then
+ echo "Warning: Shared library still contains TEXTREL records." ;
+--
+2.7.3
+
+From b11541f4beaf8395dd90de53b57933661e120b0a Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 11 Jun 2016 15:34:57 +0300
+Subject: [PATCH 3/3] build: ignore DL_EXPORT on non windows
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ cryptlib.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/cryptlib.h b/cryptlib.h
+index 61cf338..4738852 100644
+--- a/cryptlib.h
++++ b/cryptlib.h
+@@ -122,6 +122,7 @@
+ #define C_CHR char
+ #define C_STR C_CHR *
+ #define C_RET int
++ #define DL_EXPORT(type) type
+ #endif /* Windows vs.everything else function types */
+
+ /* Symbolic defines to make it clearer how the function parameters behave */
+--
+2.7.3
+
diff --git a/dev-libs/cryptlib/files/cryptlib-3.4.3-zlib.patch b/dev-libs/cryptlib/files/cryptlib-3.4.3-zlib.patch
new file mode 100644
index 000000000000..26c723c79406
--- /dev/null
+++ b/dev-libs/cryptlib/files/cryptlib-3.4.3-zlib.patch
@@ -0,0 +1,55 @@
+From 70b00d882e9ff1e17bb82b3e722def0b71f2374a Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 11 Jun 2016 15:15:25 +0300
+Subject: [PATCH 2/2] build: use system zlib
+
+this should be a toggle of build system not hard coded.
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ envelope/envelope.h | 6 +-----
+ makefile | 4 ++--
+ 2 files changed, 3 insertions(+), 7 deletions(-)
+
+diff --git a/envelope/envelope.h b/envelope/envelope.h
+index 028f4b2..4ef6b20 100644
+--- a/envelope/envelope.h
++++ b/envelope/envelope.h
+@@ -17,11 +17,7 @@
+ #endif /* Compiler-specific includes */
+ #endif /* _STREAM_DEFINED */
+ #ifdef USE_COMPRESSION
+- #if defined( INC_ALL )
+- #include "zlib.h"
+- #else
+- #include "zlib/zlib.h"
+- #endif /* Compiler-specific includes */
++ #include <zlib.h>
+ #endif /* USE_COMPRESSION */
+
+ /****************************************************************************
+diff --git a/makefile b/makefile
+index c762d02..24c180a 100644
+--- a/makefile
++++ b/makefile
+@@ -283,7 +283,7 @@ ZLIBOBJS = $(OBJPATH)adler32.o $(OBJPATH)deflate.o $(OBJPATH)inffast.o \
+ OBJS = $(BNOBJS) $(CERTOBJS) $(CRYPTOBJS) $(CTXOBJS) $(DEVOBJS) \
+ $(ENCDECOBJS) $(ENVOBJS) $(HASHOBJS) $(IOOBJS) $(KEYSETOBJS) \
+ $(KRNLOBJS) $(LIBOBJS) $(MECHOBJS) $(MISCOBJS) $(SESSOBJS) \
+- $(ZLIBOBJS) $(OSOBJS)
++ $(OSOBJS)
+
+ # Object files for the self-test code
+
+@@ -1483,7 +1483,7 @@ $(LIBNAME): $(OBJS) $(EXTRAOBJS) $(TESTOBJS)
+
+ $(SLIBNAME): $(OBJS) $(EXTRAOBJS) $(TESTOBJS)
+ @./tools/buildsharedlib.sh $(OSNAME) $(SLIBNAME) $(LD) \
+- $(STRIP) $(OBJS) $(EXTRAOBJS)
++ $(STRIP) $(OBJS) $(EXTRAOBJS) -lz
+
+ $(DYLIBNAME): $(OBJS) $(EXTRAOBJS) $(TESTOBJS)
+ @$(LD) -dynamiclib -compatibility_version $(MAJ).$(MIN) \
+--
+2.7.3
+