summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-12-13 00:51:04 +0100
committerSebastian Pipping <sping@gentoo.org>2017-12-13 01:09:30 +0100
commit59906d45683fd54257d0d4706bc0ae9061a2f33a (patch)
tree4b03485cbd8731fe0ebef3a021959a877423efcd
parentx11-themes/zuki-themes: 3.24.3 (diff)
downloadgentoo-59906d45683fd54257d0d4706bc0ae9061a2f33a.tar.gz
gentoo-59906d45683fd54257d0d4706bc0ae9061a2f33a.tar.bz2
gentoo-59906d45683fd54257d0d4706bc0ae9061a2f33a.zip
dev-python/autopep8: 1.3.3
Package-Manager: Portage-2.3.16, Repoman-2.3.6
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-1.3.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 106ed7f3e316..704e2cea054d 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1 +1,2 @@
DIST autopep8-1.3.2.tar.gz 107915 BLAKE2B 3148f12616babc26415fc138d5d9e2d2a83cc735449cea54870662dabdfebfd298d96ca716ee62c9143049a2abf05e6a597b0ec6bab90c557dae63999794ea25 SHA512 cb9a5e297ce705722d5e65472dbe749e57fa12fe8dee0d4c3dc20d9e885e0d885339627667110318c89c6bf7e337203a7831c0e2217e5a5d7951edcb98d3df4f
+DIST autopep8-1.3.3.tar.gz 108639 BLAKE2B d2e6f6f334dfeb5e8ae33f4460c9344ec6b1e234e7f714c7602fae72f1ca5608e12145c40a39b14d28e1d79b0dd91855493d87947407428ba4c1d87834156626 SHA512 e327d58311f74c8bb9f18b99f8d866c071166e94f43912b35eedc6062267d4cdb5842bde7c54426c751b1bb76103ec11eb8daa682772a1f71c50962811dbc694
diff --git a/dev-python/autopep8/autopep8-1.3.3.ebuild b/dev-python/autopep8/autopep8-1.3.3.ebuild
new file mode 100644
index 000000000000..32c6043fa952
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.python.org/pypi/autopep8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}