summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-28 02:05:49 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-03-28 02:50:38 +0200
commit59a6af4806319d30af8b8e2e9cc398d2e9f11cf1 (patch)
tree3ac4e6ffa2ad248cdafa93079dc20f32a021c200
parentapp-emacs/cider: bump to 1.7.0 (diff)
downloadgentoo-59a6af4806319d30af8b8e2e9cc398d2e9f11cf1.tar.gz
gentoo-59a6af4806319d30af8b8e2e9cc398d2e9f11cf1.tar.bz2
gentoo-59a6af4806319d30af8b8e2e9cc398d2e9f11cf1.zip
app-emacs/citar: bump to 1.3.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/citar/Manifest1
-rw-r--r--app-emacs/citar/citar-1.3.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/citar/Manifest b/app-emacs/citar/Manifest
index 66db9053f0a3..3277625f58f0 100644
--- a/app-emacs/citar/Manifest
+++ b/app-emacs/citar/Manifest
@@ -1,3 +1,4 @@
DIST citar-1.0.tar.gz 1339812 BLAKE2B 2093cc820199219ec70f99a746c630f2b8e6b4d464b1457d7b7db1c5c953138e7dd5ac55e21b13e7417dd0a764b6f1caaf400af353ecce9fb7e1bc578f570b0d SHA512 7f02a4e41a927c2c7c625189fa38caea8f0fc5616dd3487a93f71a373d1e4a124dd1cc520778a1ff2fa6dd7c3b619b539e3b0e47cb9caf7edd16e27e9d739585
DIST citar-1.1.tar.gz 1340039 BLAKE2B b2090a35a582918300f5e4bb2188d463630988830305aa4bb5e1e27f45ff8c96ca35458e610e13658b2120af497f9b877054a6fbebda48e0a4d87824ef48e9c8 SHA512 2b1924ef1a05a170eea31f844055b914410cd35613eda6604f08164818a8fc5480fc5a6d6f055ba95331b517305e51a6e671214cc88fccbda2430ae9b06dda49
DIST citar-1.2.0.tar.gz 1417090 BLAKE2B 40673ee0f2ee5b4f86928e140714a517958d261c632ea1e7bcb3dcd3dde3a0bb9baaaa1107f50447f1d8e87485570033afbf0c652fa6b3f1fbffeda7b7df04c3 SHA512 31f817de77bc8fe9e2fdf96ac7df521ebe5685cf49a2a78cd2b1cd51e538165bde36fc8515c2fd7c20d4c6160372fdf37c1b870b12167f946c0f3934edd5fb7c
+DIST citar-1.3.1.tar.gz 1602843 BLAKE2B 0abf90120860777e13ac495681bb1e07d6c352bc17aef173b32e60fc2d754a37628670b57e17335bc5e549c451b9565a58c8547952a5b78d6335adc7601b8f5e SHA512 a00e7ff5331fa3a161151292dd4a9d3c0a7211051f5ddf528cfe7d4a48377af64f3719f57c76013b45a30082fbfd435d98196e757169970a22bb662f49ccd346
diff --git a/app-emacs/citar/citar-1.3.1.ebuild b/app-emacs/citar/citar-1.3.1.ebuild
new file mode 100644
index 000000000000..1e1644827e32
--- /dev/null
+++ b/app-emacs/citar/citar-1.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs package to quickly find and act on bibliographic references"
+HOMEPAGE="https://github.com/emacs-citar/citar/"
+SRC_URI="https://github.com/emacs-citar/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-emacs/citeproc-el
+ app-emacs/parsebib
+"
+BDEPEND="${RDEPEND}"
+
+# Embark integration has it's own package on MELPA, and it is probably better
+# to split them. https://melpa.org/#/citar-embark
+ELISP_REMOVE="citar-embark.el"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l test/citar-file-test.el \
+ -l test/citar-format-test.el \
+ -l test/citar-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}