summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-29 09:22:30 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-29 09:22:30 +0200
commit59acee5291513d54bf5ed1ee873c769ea9b1ffe8 (patch)
treeff2bd9d998daeae3ed68e924499fdef8a3c69793
parentdev-python/psycopg: Stabilize 2.9.3 arm64, #832285 (diff)
downloadgentoo-59acee5291513d54bf5ed1ee873c769ea9b1ffe8.tar.gz
gentoo-59acee5291513d54bf5ed1ee873c769ea9b1ffe8.tar.bz2
gentoo-59acee5291513d54bf5ed1ee873c769ea9b1ffe8.zip
dev-ros/ament_lint_cmake: enable py3.{9,10} for live version
Closes: https://bugs.gentoo.org/832244 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-ros/ament_lint_cmake/ament_lint_cmake-9999.ebuild23
1 files changed, 6 insertions, 17 deletions
diff --git a/dev-ros/ament_lint_cmake/ament_lint_cmake-9999.ebuild b/dev-ros/ament_lint_cmake/ament_lint_cmake-9999.ebuild
index b926d90a9384..c756912e7c5c 100644
--- a/dev-ros/ament_lint_cmake/ament_lint_cmake-9999.ebuild
+++ b/dev-ros/ament_lint_cmake/ament_lint_cmake-9999.ebuild
@@ -1,22 +1,21 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
-
inherit distutils-r1
ROS_PN="ament_lint"
-if [ "${PV#9999}" != "${PV}" ] ; then
+if [[ "${PV}" == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
+ S="${WORKDIR}/${P}/${PN}"
else
SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="Lint CMake code using cmakelint and generate xUnit test result files"
@@ -24,23 +23,13 @@ HOMEPAGE="https://github.com/ament/ament_lint"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE="test"
-RDEPEND="
-"
-DEPEND="${RDEPEND}
+BDEPEND="
test? (
dev-ros/ament_flake8[${PYTHON_USEDEP}]
dev-ros/ament_pep257[${PYTHON_USEDEP}]
dev-ros/ament_copyright[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)
"
-BDEPEND=""
distutils_enable_tests pytest