summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-09-30 17:38:06 -0400
committerMike Gilbert <floppym@gentoo.org>2018-09-30 18:47:43 -0400
commit59c0d28a9f6c6c8b44dfab3c041832d8a708ab4c (patch)
tree2c47cc632144e3c13cc05fe53b85a46ebd6d5480
parentsys-apps/iproute2-4.17.0: arm64 stable (bug #666778) (diff)
downloadgentoo-59c0d28a.tar.gz
gentoo-59c0d28a.tar.bz2
gentoo-59c0d28a.zip
www-client/chromium: allow forced clang to be disabled
Package-Manager: Portage-2.3.50_p10, Repoman-2.3.11_p17 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--www-client/chromium/chromium-71.0.3559.6.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/www-client/chromium/chromium-71.0.3559.6.ebuild b/www-client/chromium/chromium-71.0.3559.6.ebuild
index c458dff87746..a46167b6ff4d 100644
--- a/www-client/chromium/chromium-71.0.3559.6.ebuild
+++ b/www-client/chromium/chromium-71.0.3559.6.ebuild
@@ -101,11 +101,16 @@ DEPEND="${COMMON_DEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
- >=sys-devel/clang-5
virtual/pkgconfig
dev-vcs/git
"
+: ${CHROMIUM_FORCE_CLANG=yes}
+
+if [[ ${CHROMIUM_FORCE_CLANG} == yes ]]; then
+ DEPEND+=" >=sys-devel/clang-5"
+fi
+
if ! has chromium_pkg_die ${EBUILD_DEATH_HOOKS}; then
EBUILD_DEATH_HOOKS+=" chromium_pkg_die";
fi
@@ -380,7 +385,7 @@ src_configure() {
# Make sure the build system will use the right tools, bug #340795.
tc-export AR CC CXX NM
- if ! tc-is-clang; then
+ if [[ ${CHROMIUM_FORCE_CLANG} == yes ]] && ! tc-is-clang; then
# Force clang since gcc is pretty broken at the moment.
CC=${CHOST}-clang
CXX=${CHOST}-clang++