summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-15 23:45:40 +0000
committerJimi Huotari <chiitoo@gentoo.org>2023-02-16 21:16:17 +0200
commit59d072a9f459d7bea68b571dc6497f82257b3ad9 (patch)
tree628162842238d5ea9cc75320085fddcce43ad0a0
parentgnome-base/gvfs: Stabilize 1.50.3 sparc, #893302 (diff)
downloadgentoo-59d072a9.tar.gz
gentoo-59d072a9.tar.bz2
gentoo-59d072a9.zip
dev-util/lxqt-build-tools: bump the minimum C++ compatibility level
- https://github.com/lxqt/lxqt-build-tools/pull/83 Bug: https://bugs.gentoo.org/894468 Signed-off-by: Ghiunhan Mamut <venerix@redcorelinux.org> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--dev-util/lxqt-build-tools/files/lxqt-build-tools-cpp17-standard.patch30
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0-r1.ebuild30
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/files/lxqt-build-tools-cpp17-standard.patch b/dev-util/lxqt-build-tools/files/lxqt-build-tools-cpp17-standard.patch
new file mode 100644
index 000000000000..21009b89c6f4
--- /dev/null
+++ b/dev-util/lxqt-build-tools/files/lxqt-build-tools-cpp17-standard.patch
@@ -0,0 +1,30 @@
+Gentoo Bug: https://bugs.gentoo.org/894468
+Upstream: https://github.com/lxqt/lxqt-build-tools/pull/83
+
+From 4a3a7038b1927dc43942a930db103023efdcbe2c Mon Sep 17 00:00:00 2001
+From: Simon Quigley <simon@tsimonq2.net>
+Date: Wed, 25 Jan 2023 09:39:41 -0600
+Subject: [PATCH] Bump the minimum compatibility level to C++17.
+
+---
+ cmake/modules/LXQtCompilerSettings.cmake | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/cmake/modules/LXQtCompilerSettings.cmake b/cmake/modules/LXQtCompilerSettings.cmake
+index a8cb16d..acba891 100644
+--- a/cmake/modules/LXQtCompilerSettings.cmake
++++ b/cmake/modules/LXQtCompilerSettings.cmake
+@@ -181,11 +181,11 @@ endif()
+
+
+ #-----------------------------------------------------------------------------
+-# CXX14 requirements - no checks, we just set it
++# CXX17 requirements - no checks, we just set it
+ #-----------------------------------------------------------------------------
+ set(CMAKE_CXX_STANDARD_REQUIRED True)
+ set(CMAKE_CXX_EXTENSIONS OFF)
+-set(CMAKE_CXX_STANDARD 14 CACHE STRING "C++ ISO Standard")
++set(CMAKE_CXX_STANDARD 17 CACHE STRING "C++ ISO Standard")
+
+
+ #-----------------------------------------------------------------------------
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0-r1.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0-r1.ebuild
new file mode 100644
index 000000000000..ecbde452e97b
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=dev-qt/qtcore-5.15:5
+"
+RDEPEND="${DEPEND}"
+
+# https://bugs.gentoo.org/894468
+# https://github.com/lxqt/lxqt-build-tools/pull/83
+PATCHES=( "${FILESDIR}"/"${PN}"-cpp17-standard.patch )