summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-10-19 11:46:58 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-20 09:44:52 +0200
commit59e8a2ae57009b41a734c7ae52f8918f08688933 (patch)
treed26fc658e24100afacaa6936c56fc8cbacfb5d81
parentdev-python/ImageHash: version bump to 3.7. (diff)
downloadgentoo-59e8a2ae57009b41a734c7ae52f8918f08688933.tar.gz
gentoo-59e8a2ae57009b41a734c7ae52f8918f08688933.tar.bz2
gentoo-59e8a2ae57009b41a734c7ae52f8918f08688933.zip
dev-python/matplotlib2tikz: version bump to 0.6.13.
Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5984
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.6.13.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
index 63de2e8e0061..0360adf8c927 100644
--- a/dev-python/matplotlib2tikz/Manifest
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -1 +1,2 @@
DIST matplotlib2tikz-0.6.11.tar.gz 524298 SHA256 79c9f141fd802fe5863d2eaff6c67476d02ca474433e65990c935241a2591994 SHA512 eda5042f1db35436ca56256cb858fa11b48d497f621183475d69381b0b10ac67f9447522e1b78c1a331337e34eb159b5ffeef9655a8c0dc4ccab22b7afcb5e96 WHIRLPOOL b09025b9444e0a0ec122fbb7d6d90e32e043c3a86e8b7454ac3fdc0ba03374f5648491a4564bae7ef622a536f4ec92e762a68816d64621da6df44fea2c404c8c
+DIST matplotlib2tikz-0.6.13.tar.gz 524735 SHA256 ce6de9226316d4b5ae3ce0d57c7cf445d219e6842bdc041820c0c39ee9af339c SHA512 f42e96ab60005b96f9327e34ff9df444e9a371334c77b0bad85343beeb20a5c4c2df5539fd0200cf306a4cfed6926f191d547bf2ed69a98c4a9f2e1c2ae0da7b WHIRLPOOL f6ff4d4d8837394e1aacc2c66686cc711b64b6d7aad95620e402b4f1494436b8d2248ce8fbb947ec9d4a93442aba1c1cf03eed9423ff19f31b98060678274785
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.13.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.13.ebuild
new file mode 100644
index 000000000000..28505b0459e4
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.13.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="https://github.com/nschloe/matplotlib2tikz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/ImageHash[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-tex/pgf
+ )"
+
+# we have not succeeded in getting the tests to work yet ;-)
+RESTRICT="test"
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx py.test -v || die "Tests failed with ${EPYTHON}"
+}