summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-02-07 09:37:58 +0000
committerMarek Szuba <marecki@gentoo.org>2023-02-07 09:42:03 +0000
commit59ee7a9fc3dbbe672cff2e84b398d0e7c189d677 (patch)
tree51ea604e3ffe4d6ee07b8b3057870a74f3b1171e
parentsci-chemistry/pymol: support msgpack-5 (diff)
downloadgentoo-59ee7a9fc3dbbe672cff2e84b398d0e7c189d677.tar.gz
gentoo-59ee7a9fc3dbbe672cff2e84b398d0e7c189d677.tar.bz2
gentoo-59ee7a9fc3dbbe672cff2e84b398d0e7c189d677.zip
dev-libs/msgpack-3.3.0: block dev-cpp/msgpack-cxx
As far as file collisions are concerned this could be made conditional on USE=cxx, however it is probably a bad idea to mix different major versions of msgpack overall. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-libs/msgpack/msgpack-3.3.0-r1.ebuild (renamed from dev-libs/msgpack/msgpack-3.3.0.ebuild)5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-libs/msgpack/msgpack-3.3.0.ebuild b/dev-libs/msgpack/msgpack-3.3.0-r1.ebuild
index d6e70be0a836..db548946d8c3 100644
--- a/dev-libs/msgpack/msgpack-3.3.0.ebuild
+++ b/dev-libs/msgpack/msgpack-3.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,7 +22,8 @@ IUSE="boost +cxx doc examples static-libs test"
RESTRICT="!test? ( test )"
BDEPEND="doc? ( app-doc/doxygen[dot] )"
-RDEPEND="boost? ( dev-libs/boost[context,${MULTILIB_USEDEP}] )"
+RDEPEND="boost? ( dev-libs/boost[context,${MULTILIB_USEDEP}] )
+ !dev-cpp/msgpack-cxx"
DEPEND="${RDEPEND}
test? (
>=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}]