summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-02 18:29:50 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-02 18:29:50 +0100
commit59f8ef7262c585d5e01c5db2e1897a2d94dd086e (patch)
treeeece2f4d660afe5e44b4fb5de2b4528e8d7d5c72
parentdev-python/plyr: Fix building docs (diff)
downloadgentoo-59f8ef72.tar.gz
gentoo-59f8ef72.tar.bz2
gentoo-59f8ef72.zip
dev-python/psutil: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/psutil/Manifest2
-rw-r--r--dev-python/psutil/psutil-5.9.1.ebuild44
2 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/psutil/Manifest b/dev-python/psutil/Manifest
index 0a4d14f0a4cf..08b18e83f97c 100644
--- a/dev-python/psutil/Manifest
+++ b/dev-python/psutil/Manifest
@@ -1,5 +1,3 @@
-DIST psutil-5.9.1-tests-r2.patch.xz 3516 BLAKE2B 6a16d6f89fdeb06c7aa0d9d986eba84deae5f8d2bb829c2509744f954f9b274d8a70a00f94127f1880cea71f8d7e7b85097517f8516ee6ef14f17522ee9297b2 SHA512 b69efb32cd0229056ff9fbbde963f0f01f6bf1d0820f028527f464e38a9bd4211a55bd725cc8962a20608c12c28edb24b2063f5f58b53fdb6b001fe2f95da103
-DIST psutil-5.9.1.tar.gz 479090 BLAKE2B 88f35a9134d942fa56b5fbc79753e82245c3bfdb1f640dbf3b56815b89d872517f9ee3a3945532ebd1a399c3307e160ac80394766c3b2cc7e3fb36ffdd555eef SHA512 1ddb119a10243d17d808417817ec8659d22447f12a4bbc0366c13f6587a4b0b59f4e74f6ac5d1e1a908bb5fd287be630466d32beabcb5008f6a19c24a1557c27
DIST psutil-5.9.3-tests-r1.patch.xz 3648 BLAKE2B df56e3b11da307fdd4441284d1a7928c928b36c512ef05d313ac71e76545eabaca1f6a1ea9dab301c86005ef4c9af9622e0d1c6d7be858b92b0dce9d6031440d SHA512 0d8b35fe76b1caf1265ab4ecf182c92b71714be9612418c945f39c58f384979ed36e47bdf11b11a8cf2fc3925fed60abadf4f3eaea083f6bcd6d2cddb81fb5f9
DIST psutil-5.9.3.tar.gz 483579 BLAKE2B c1b5c77483a1e280cc68aa3ae5ca39fcc3992f3c07a591bbe92278050e9517a9e9c0e17338f2932f5ec680a19c4f6958e21e4b9b02158041e76dd877b5311c21 SHA512 d226364b416823783058f19c06dae4ac1ea03f061646f01ea6953ded8fbb89aed92aa743c9e55181e4d57101f7dbbb78336043e1fc7a3bd62ff82b19f0a4efae
DIST psutil-5.9.4.tar.gz 485825 BLAKE2B ce5257e653876fc0c4bb005c964f677c0b4010f853cc7b8ff3451aa1efd7fde6b7e5d2150fb936cd38b667d5c167f180d5cae0792bdf50a8aa2e528795ed9897 SHA512 ff8d6213b153b5a3428e4f65ddbc41cb1f37caae4acab02760632107d95a50a74d3ee563f0cb2d623b37cdddd16425d2084e7f841e4a46af8988a7676f6975e6
diff --git a/dev-python/psutil/psutil-5.9.1.ebuild b/dev-python/psutil/psutil-5.9.1.ebuild
deleted file mode 100644
index f47166770945..000000000000
--- a/dev-python/psutil/psutil-5.9.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-TEST_PATCH=psutil-5.9.1-tests-r2.patch
-DESCRIPTION="Retrieve information on running processes and system utilization"
-HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.org/project/psutil/"
-SRC_URI="
- mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- https://dev.gentoo.org/~mgorny/dist/${TEST_PATCH}.xz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${WORKDIR}/${TEST_PATCH}"
-)
-
-python_test() {
- # Since we are running in an environment a bit similar to CI,
- # let's skip the tests that are disabled for CI
- local -x TRAVIS=1
- local -x APPVEYOR=1
- local -x GITHUB_ACTIONS=1
- local -x GENTOO_TESTING=1
- "${EPYTHON}" psutil/tests/runner.py ||
- die "tests failed with ${EPYTHON}"
-}
-
-python_compile() {
- # Force -j1 to avoid .o linking race conditions
- local MAKEOPTS=-j1
- distutils-r1_python_compile
-}