summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-06 21:24:09 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-06 23:47:09 +0100
commit5a15dd0a80a69c1984004a8d7cdb3d449dcc338f (patch)
tree55f8e39c14f09077a313c0ad870a2f6496a5f760
parentprofiles.desc: Add m68k 23.0 profiles (exp only) (diff)
downloadgentoo-5a15dd0a80a69c1984004a8d7cdb3d449dcc338f.tar.gz
gentoo-5a15dd0a80a69c1984004a8d7cdb3d449dcc338f.tar.bz2
gentoo-5a15dd0a80a69c1984004a8d7cdb3d449dcc338f.zip
dev-lang/typescript: bump to 5.3.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/typescript-5.3.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
index 97d66e1bd023..8e01a45db49d 100644
--- a/dev-lang/typescript/Manifest
+++ b/dev-lang/typescript/Manifest
@@ -1,2 +1,3 @@
DIST typescript-5.2.2.tgz 7230699 BLAKE2B c7e0908ab86f80d0b4863e4ea2ade49101735ea00840407be34afb62ff14156eb00f97504640d08da0687d1aac2a3b666b2f377b68110635f92471f9c1260988 SHA512 988e16ae91ec6c221cc13f5c178159bebf3441478abec52c52f283a11f97ffb5c7407f7cc580fc607660ec036dcf61ad66dfc206ad90274b6190624c1dfa9cd7
DIST typescript-5.3.2.tgz 5761922 BLAKE2B e23598be7987fe705e81b24c3cea01dd7af012c2254e97c414a48244bacb155b95cfb81a3b4a25e26374ee2169dee2cbd70e16939a0e08e832ca0abd76711c96 SHA512 ea5f91c8dcbba001c37f10b8173489733f6f9e34cac6b2e90c6e4cd95bb8487455360eb1cea669e8b61247dce3a904eef0353f7f9c70c547400ce91bac85f681
+DIST typescript-5.3.3.tgz 5761919 BLAKE2B 629d2d97a9d57f63cd693a6d77cc385058778c4e4de6002f5e2646c64d1b8ff80386290435b2c838f647bc76f626e4dfd9613e1237d53fa5e4b98f503fbdf9ea SHA512 a5759cadac4cd2ec404beb4dd001bf045d93caa9873b4d78674ef452c27ea45bd8b914aaf0a1fc0e65a99db5ded2910f0c75d957715c01b2648a3279a0d1275b
diff --git a/dev-lang/typescript/typescript-5.3.3.ebuild b/dev-lang/typescript/typescript-5.3.3.ebuild
new file mode 100644
index 000000000000..598301d43b33
--- /dev/null
+++ b/dev-lang/typescript/typescript-5.3.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}"/package
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}"/usr
+ --progress false
+ --verbose
+ )
+ npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
+
+ dodoc *.md *.txt
+}