summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-09 09:57:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-09 10:22:55 +0300
commit5a1ac8132d43664d0c9805501d85eeb49e57ed48 (patch)
tree33deda0fea3c11c70b0f109a3fd71904541c61d5
parentdev-python/sqlalchemy: add 1.4.14 (diff)
downloadgentoo-5a1ac8132d43664d0c9805501d85eeb49e57ed48.tar.gz
gentoo-5a1ac8132d43664d0c9805501d85eeb49e57ed48.tar.bz2
gentoo-5a1ac8132d43664d0c9805501d85eeb49e57ed48.zip
dev-python/jupyter-server-proxy: add 3.2.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/jupyter-server-proxy/Manifest1
-rw-r--r--dev-python/jupyter-server-proxy/jupyter-server-proxy-3.2.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jupyter-server-proxy/Manifest b/dev-python/jupyter-server-proxy/Manifest
index 62c121a51426..a0472e6275fb 100644
--- a/dev-python/jupyter-server-proxy/Manifest
+++ b/dev-python/jupyter-server-proxy/Manifest
@@ -1 +1,2 @@
DIST jupyter-server-proxy-3.2.1.tar.gz 119991 BLAKE2B c94c2af6c550a2f5ba01facfa7f93bb3d7cf4334ea374c390b1a10478eced7104c31f9eadfac7e5eb9f20cc866cc6cc1d2ecd0eaa76009cebb25557346df3a3b SHA512 abd5730eac1fc7939732f0163d7e5c208057f77a1912efdf432b14564ea7e8cf6e81228fe7233e1e972af7ea8a813ef322782ff200000e3bd3dbd0384c7175b2
+DIST jupyter-server-proxy-3.2.2.tar.gz 121353 BLAKE2B 4f7c8af14a149f13272ea2802e830b38a5167f1de80dab21e1d175cb96ba3b908bd268f6dbb02cfd4fb8991ffb3315c044405925358904f82b26d55f74f97dbe SHA512 320765a8a8b1c6f213bd9c8cf514aac44f40ce93fb27fa890d8c6a9ae158f92f1b3a7119b47067db1c4f38925815f647559b3c618a9a85553cdbf7d2dc0a3872
diff --git a/dev-python/jupyter-server-proxy/jupyter-server-proxy-3.2.2.ebuild b/dev-python/jupyter-server-proxy/jupyter-server-proxy-3.2.2.ebuild
new file mode 100644
index 000000000000..4b6f600dd84b
--- /dev/null
+++ b/dev-python/jupyter-server-proxy/jupyter-server-proxy-3.2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Jupyter notebook server extension to proxy web services"
+HOMEPAGE="https://github.com/jupyterhub/jupyter-server-proxy"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+# The GitHub tarball includes the tests, but does not have the js stuff we need
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.0[${PYTHON_USEDEP}]
+ >=dev-python/simpervisor-0.4[${PYTHON_USEDEP}]
+"
+BDEPEND="dev-python/jupyter_packaging[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}