summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-29 09:01:24 +0200
committerMichał Górny <mgorny@gentoo.org>2020-03-29 09:01:24 +0200
commit5a1bc0be79c5c3d285e5bddaccded4ea17a85533 (patch)
treebe6cb8f6ecad3a6cd48603ce3fe51e0994988c89
parentdev-python/redis-py: Stabilize 3.3.11 ALLARCHES (diff)
downloadgentoo-5a1bc0be.tar.gz
gentoo-5a1bc0be.tar.bz2
gentoo-5a1bc0be.zip
dev-python/redis-py: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/redis-py/Manifest1
-rw-r--r--dev-python/redis-py/redis-py-3.2.1.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/redis-py/Manifest b/dev-python/redis-py/Manifest
index 10df1a714989..61bdd72bbbdb 100644
--- a/dev-python/redis-py/Manifest
+++ b/dev-python/redis-py/Manifest
@@ -1,2 +1 @@
-DIST redis-py-3.2.1.tar.gz 124692 BLAKE2B fc7a773ab0a7e13f034b9efa174806b024733f9263b962599ce72e9a0c88b11964c26081375b6ae2de49939b59a561c145ae1b69c262b801f9b887befe9dcc0a SHA512 be51642a8895325c3c61993dd83c3299a9e2cefc1010e04f182833f720ff161bea43d3a57d28afba991949fcf6e967c4f778002967641bffe651d5db384f2e08
DIST redis-py-3.3.11.tar.gz 131072 BLAKE2B 6becafba3da22bae796a4a9ba55d11a61d9ed1a8b693a734d4ef3f0e463c0c39a05c01546225f69eb36a788779d6e45d0136e1a6d6856ec63c3dd07994b5db9a SHA512 a32327fcebc6242367c0eda6c6dcd1a15d5d575527af2e9de0d76e05bc4afc7402566d9254e467663b81907a310731af3041236b6b135f3b8ff1429a502c1000
diff --git a/dev-python/redis-py/redis-py-3.2.1.ebuild b/dev-python/redis-py/redis-py-3.2.1.ebuild
deleted file mode 100644
index 77bcb3a7cb90..000000000000
--- a/dev-python/redis-py/redis-py-3.2.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-MY_PN="redis"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python client for Redis key-value store"
-HOMEPAGE="https://github.com/andymccurdy/redis-py"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-db/redis
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.7.0[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- # Make sure that tests will be used from BUILD_DIR rather than cwd.
- mv tests tests-hidden || die
-
- # Correct local import patch syntax
- sed -e 's:from .conftest:from conftest:' \
- -i tests-hidden/{test_commands.py,test_connection_pool.py,test_encoding.py,test_lock.py,test_pubsub.py} \
- || die
-}
-
-python_compile() {
- distutils-r1_python_compile
-
- if use test; then
- cp -r tests-hidden "${BUILD_DIR}"/tests || die
- fi
-}
-
-python_test() {
- local sock="${T}/redis.sock"
-
- "${EPREFIX}/usr/sbin/redis-server" - <<- EOF
- daemonize yes
- pidfile "${T}/redis.pid"
- unixsocket ${sock}
- EOF
-
- PYTHONPATH="${S}:${S}/tests-hidden"
- esetup.py test --verbose
- kill $(<"${T}/redis.pid")
-}